This forum uses cookies
This forum makes use of cookies to store your login information if you are registered, and your last visit if you are not. Cookies are small text documents stored on your computer; the cookies set by this forum can only be used on this website and pose no security risk. Cookies on this forum also track the specific topics you have read and when you last read them. Please confirm whether you accept or reject these cookies being set.

Uponor?
#1
Hello,

Did anyone connected LM to the Uponor Smatrix controllers? It looks like they are on Modbus RTU.

I did an integration trough they'r KNX gateway (R-147-KNX) but that's a PITA to do, any error in configuration throws the complete gateway offline.

Br, Z
Reply
#2
Hi
I don't know this product but by looking here https://issuu.com/uponor.com/docs/uponor...4639be57ec I can tell that modbus integration should be possible as we support all modbus functions.  Connect it and use RTU read test. Profile looks fairly simple.
It use RS232 so you have to change interface to /dev/RS232
BR
Reply
#3
(10.08.2018, 15:37)Daniel. Wrote: Hi
I don't know this product but by looking here https://issuu.com/uponor.com/docs/uponor...4639be57ec I can tell that modbus integration should be possible as we support all modbus functions.  Connect it and use RTU read test. Profile looks fairly simple.
It use RS232 so you have to change interface to /dev/RS232
BR

Here is in more readable format. But this describes only one application (4-zone heat/cool controller). What I have here is room controllers (underfloor, radiator ...) and they internally communicate over RS485, probably Modbus RTU.
I tought that maybe somebody have experience with this, it would be much easier if the script can read the controllers and autogenerate all the needed stuff.

I'll try to get some traffic log tomorrow and see what can be done with it.
Reply
#4
You need manual which describes all modbus registry. Contact manufacture for this info.
Reply
#5
I did all i could today, unfortunately it doesn't look like Modbus at all. Although in the documentation it say Modbus where they describe the connector.

I've tried all combinations of speed, parity, stop bits for the most common speeds (9600, 19200, 38400), switched A/B (and got garbage), and additionally stepped trough all other speeds with 8E1, only 19200 give reasonable looking results.

Somewhere in this screenshot is buried a write of value 33.32. Does anyone recognize this format?


Attached Files Image(s)
       
Reply


Forum Jump: