This forum uses cookies
This forum makes use of cookies to store your login information if you are registered, and your last visit if you are not. Cookies are small text documents stored on your computer; the cookies set by this forum can only be used on this website and pose no security risk. Cookies on this forum also track the specific topics you have read and when you last read them. Please confirm whether you accept or reject these cookies being set.

Mosaic 3.0 Beta - bug report
#1
Hi All

We uploaded beta version of Mosaic 3.0 to the app store. Feel free to play with it and please report here any bugs.
There will be bugs so please don't use it for regular projects.
This app will not affect your current Mosaic project as all configs are saved separate so you can play freely.

BR
Reply
#2
In widget creator there is no possibility to add some control element. Generally this is very good step, because Mosaic goes more and more elastic and powerful. Unfortunately still it is very slow on init also with LM which has only 350 objects.
Done is better than perfect
Reply
#3
Hi
In widget creator you probably didn't close the settings tab. When you say slow, can you give some more info or share your project?

BR


Attached Files Image(s)
   
Reply
#4
Probably this is not related to LM traditional visualisation or project because on this LM I has no visu pages and only a few scripts. Maybe this is related to number of objects because this was also visible in old visu when on init all object related stuff run for further using it by controls and in Custom JS.

If it is about adding control elements, you're rightWink

Very good job, now widgets are much more reusable, powerful. And very nice iconsSmile
Done is better than perfect
Reply
#5
Thanks, play with global styles in settings.
Reply
#6
I will. I don'y know if maybe I am doing something in bad way, but in editor I've added widget with 1 control element which is connected to real object. It is visible in editor on main view and in the Kitchen room, but not in app, where Kitchen is visible but not this widget.


Attached Files
.json   mosaic-backup.json (Size: 2.6 KB / Downloads: 9)
Done is better than perfect
Reply
#7
(24.10.2018, 08:06)buuuudzik Wrote: I will. I don'y know if maybe I am doing something in bad way, but in editor I've added widget with 1 control element which is connected to real object. It is visible in editor on main view and in the Kitchen room, but not in app, where Kitchen is visible but not this widget.

There was no object linked. Make sure you press update after configuration of an element is finished.
Reply
#8
If it is about some new functions of mosaic maybe you can add canvas with possibility to add JS code for it. I know that it can be created by control for embedding HTML code but maybe this is good option. It could be used for creating some animated data visualisationWink
Done is better than perfect
Reply
#9
(24.10.2018, 08:15)buuuudzik Wrote: If it is about some new functions of mosaic maybe you can add canvas with possibility to add JS code for it. I know that it can be created by control for embedding  HTML code but maybe this is good option. It could be used for creating some animated data visualisationWink

You can add also SVG code to custom widget where you can hide JS
Reply
#10
(24.10.2018, 08:13)Daniel. Wrote:
(24.10.2018, 08:06)buuuudzik Wrote: I will. I don'y know if maybe I am doing something in bad way, but in editor I've added widget with 1 control element which is connected to real object. It is visible in editor on main view and in the Kitchen room, but not in app, where Kitchen is visible but not this widget.

There was no object linked. Make sure you press update after configuration of an element is finished.

I've refreshed page, I see that objects are connected in edited element on widget, but I've clicked 'Update' in element settings and 'Save' in widget creator. But still after refreshing app there is no change and there is no control element on main screen and no control element in the Kitchen. I've attached my simple projectWink I've tried hard refresh browser and tested it on 2 different browsers (Firefox and Chrome).


Attached Files
.json   mosaic-backup.json (Size: 2.23 KB / Downloads: 6)
Done is better than perfect
Reply
#11
I have the same, I wasn't looking on the user app. We will check it. Thanks.

Add one normal widget and then it will be visible. Seems a bug when only custom widget is added.
Reply
#12
Looking like a huge step in the right direction  Smile  Great work!

Mostly some widget creator stuff i got comments for.
When first adding a custom widget to a page, it did not show up until adding another widget on the same page.
I think most elements that can show values should have a maximum decimal setting`?
The toggle switch should change color to show on/off, as it is now, hard to tell if it could be on or off.
My icon element has multiple uploads for icons, but why`? Status on/off?
The option value element is great, but changes width depending on length of text, possibility to set a fixed with on these to make it look consistent would be great.
Generally a lot of the elements don't line up when snapping to grid.
Should maybe be an integrated icon library`? 
Choose icon for custom functions, General does not have an icon at all by standard it seems?

Setting for all widgets to only show on homescreen if certain value`? 
Older "bug" not related to 3.0. I think the Co2/humidity/temp widget should support 2-byte float for humidity as most knx sensors i've used this far outputs that. Although KNX dpt note says "This DPT is only used in case of universal I/O modules which can provide any sensor value in 2 octet float format."

Best regards, Jørn.
Reply
#13
Thanks Jørn
I will answer between your lines

When first adding a custom widget to a page, it did not show up until adding another widget on the same page.
- Known bug
I think most elements that can show values should have a maximum decimal setting`?
- We plan to add this to universal display object (15C) the others should have fixed decimals, will check
The toggle switch should change color to show on/off, as it is now, hard to tell if it could be on or off.
- Good point
My icon element has multiple uploads for icons, but why`? Status on/off?
- Yes, description is missing
The option value element is great, but changes width depending on length of text, possibility to set a fixed with on these to make it look consistent would be great.
- Good point
Generally a lot of the elements don't line up when snapping to grid.
- Will check this it all depend of type and size
Should maybe be an integrated icon library`?
- We think of making an online library for icons.
Choose icon for custom functions, General does not have an icon at all by standard it seems?
- Not sure what you mean by this.


BR
Reply
#14
(26.10.2018, 09:53)Daniel. Wrote: Choose icon for custom functions, General does not have an icon at all by standard it seems?
- Not sure what you mean by this.


BR

   

Best regards, Jørn.
Reply
#15
Chart widget does not show any data if series source is trend log
   
   
Reply
#16
After installation this Mosaic version I've notice such things in Logs:

Code:
unknown 24.10.2018 10:22:01
* string: coloron
unknown 24.10.2018 10:22:01
* string: shape
unknown 24.10.2018 10:22:01
* string: iconon
unknown 24.10.2018 10:22:01
* string: on_text
unknown 24.10.2018 10:22:01
* string: inverse
unknown 24.10.2018 10:22:01
* string: iconoff

I have only I dummy room with 1 custom widget which is only visible in Editor. Maybe this is related with my last postWink
Done is better than perfect
Reply
#17
@gtsamis thanks this is known bug.

@buuuudzik OK I used your project and have the same, funny bug.
Reply
#18
Same strange logs as buuuudzik's on my installation too.
Also I can't find any way to change value's text color on the gauge widget and although it has a light icon! it appears on power functions.
   
Reply
#19
I found that Alarm icons are inverted in the custom widget:
   

On my wish list:
  • ability to add vertical slider in custom widget
  • add security (authentication) at least for settings access
Reply
#20
Any update on the problem with the Mosaic cant seem to only have widgets created in the widget creator. 
It only shows when i add an normal widget. Pages blank when i only have custom widgets.
Reply


Forum Jump: