This forum uses cookies
This forum makes use of cookies to store your login information if you are registered, and your last visit if you are not. Cookies are small text documents stored on your computer; the cookies set by this forum can only be used on this website and pose no security risk. Cookies on this forum also track the specific topics you have read and when you last read them. Please confirm whether you accept or reject these cookies being set.

File not found on LM4 (usr/lib/lua/encdec.so)
#1
Hello I have a LM4 that died at customer site last october.
I Finally have it on my desk.

Trying to access it wia WEB-browser, i get the following message:

Lua error error loading module 'encdec' from file '/usr/lib/lua/encdec.so': File not found

I tryed different links, like /apps, /Scada-vis, etc. but none report anything other than the LUA-error.

Any idea what this is?
And what to do?

Found some small sollution.
http://192.168.1.99/cgi-bin/scada/ worked.. Seems like older systems need the cgi-bin aswell.

The start-page does not work though.
This LM is running Version: 20150917
I will try to upgrade.

Paul
Reply
#2
Hi
You better just reflash it, Looks like some files got corrupted or just sing of dying card.
http://openrb.com/reflash-logicmachine3-...-software/
BR
Reply
#3
(11.01.2019, 11:35)Daniel. Wrote: Hi
You better just reflash it,  Looks like some files got corrupted or just sing of dying card.
http://openrb.com/reflash-logicmachine3-...-software/
BR

You are probably right.
After updating the FirmWare.. Start-page works, and Visu.
But now the flashsys page is suddently unresponsive..

So I can't check if I have a SD-card issue, or "just" corrupted files.
I probably just have to reflash.
I'll keep you updated on the progress.
Reply
#4
Hi,

After FW update you need to clear cache, seen this a lot..

BR,

Erwin
Reply


Forum Jump: