This forum uses cookies
This forum makes use of cookies to store your login information if you are registered, and your last visit if you are not. Cookies are small text documents stored on your computer; the cookies set by this forum can only be used on this website and pose no security risk. Cookies on this forum also track the specific topics you have read and when you last read them. Please confirm whether you accept or reject these cookies being set.

DALI address reassigning issues
I've recently faced a number of issues while trying to configure DALI drivers.
LM5 DR, two Tridonic drivers hooked up with the first DALI gateway, Watt24 DALI PS.
1. It's really not obvious that the first DALI gateway is called "internal" all small letters. Maybe you should update the documentation or something.
2. While trying to discover the devices the LM returned just one device with the address 63. Funny thing is that all of them turned on/off even having the same address. My solution is connecting them one by one and reassigning the addresses. Of course in this case you can only control them via scripts afterwards.
And here we face the issue number
3. The reassigning is weird. I connected one driver and ran commands

dalicmd('internal', 'setdtr', { addrtype = 'short', address = 63, value = 5 }) --I also tried to broadcast the setdtr command. Same result
dalicmd('internal', 'storeshortaddress', { addrtype = 'short', address = 63 }) -- the log showed both replies "true"

Then I tried to turn the light on/off using the command "arc" and address 5. Nothing happened. Moreover address 63 didn't work either.
I discovered that after I ran these commands the address of the driver became 2. Huh "arc" worked with the address 2 correctly.
After that I tried to assign 4 to another driver (after changing the wires of course). Nothing happened, it remained 63.
I played with it a couple hours and it just didn't want to change the address the way I wanted. Either it remained 63 or became unknown and i had to "reset" it via rediscovering to 63.

So my questions are
- Am I doing everything right?
- Maybe the gateway uses some other conversion type of addresses?
Value for new address should be address * 2 + 1

Forum Jump: