This forum uses cookies
This forum makes use of cookies to store your login information if you are registered, and your last visit if you are not. Cookies are small text documents stored on your computer; the cookies set by this forum can only be used on this website and pose no security risk. Cookies on this forum also track the specific topics you have read and when you last read them. Please confirm whether you accept or reject these cookies being set.

Modbus master TCP/IP stopped working
#1
Hello,

I have a project with a spacelynk from SE (HW2.0) and during the commissioning it stopped sending modbus commands (read and write).

I only added some variables and some scripts and added a app from SE called "Alert" which I need, to manage alerts.

I tested with a modbus slave software and it stopped sending commands.

Things that were already tested are no more working.

I rebooted several times but with no success !

Any suggestions ?

Thank you
Reply
#2
Any errors in modbus?
Reply
#3
Only a connection refused from a equipment that is not yet comissioned !

but last week, even with this connection refused all the communications worked fine.
Reply
#4
Is it Modbus IP or RTU? If IP you could try to reboot the slave.
Reply
#5
Ok i have managed to get it working.

I have deleted the equipment that is no yet commissioned, the one that is giving me the connection refused, and the communications seems to be working now.

Why does it stopped on that equipment ?!

Last week I had a lot of equipments that were not commissioned (without IP configurations) and everything worked fine... that's very strange.

I will continue my work. I will keep this thread updated.

(15.07.2019, 15:55)Daniel. Wrote: Is it Modbus IP or RTU? If IP you could try to reboot the slave.

everything IP.

I rebooted everything but with no success.

with Mbpoll I manually tested the slaves and the answered correctly ! Every single on !

See please my last post.
Reply
#6
So, from my tests, it seems that the modbus master tcp communications were stuck on the equipment that has no communication, like it had no timeout!

Even with several reboots it continues to get stuck.

The only solution was to delete that equipment from the list.

That was very strange.
Reply


Forum Jump: