This forum uses cookies
This forum makes use of cookies to store your login information if you are registered, and your last visit if you are not. Cookies are small text documents stored on your computer; the cookies set by this forum can only be used on this website and pose no security risk. Cookies on this forum also track the specific topics you have read and when you last read them. Please confirm whether you accept or reject these cookies being set.

Strange Modbus behaviour
#1
I have a SpaceLYnk running 2.3.0 where I'm not getting expected modbus error reporting. Initially I had 116 Modbus TCP/IP devices, but it seems the modbus library/stack hung as there are problems getting responses from the devices. I'm now setting everything up manually one by one so I can figure out which devices are causing problems. I've found the first one where I don't get the expected reply back, but there's no error in the Modbus log, nor is the device marked as red in the modbus panel. This is the first time I've experienced this. Anything I can do to test if modbus is working as expected on the SpaceLYnk?
Reply
#2
116 Modbus devices? WOW, what was the CPU load?
Modbus works fine, what type of registry are you reading? There is 2.4.0 FW out there already.
Reply
#3
(13.11.2019, 09:09)Daniel. Wrote: 116 Modbus devices? WOW, what was the CPU load?
Modbus works fine, what type of registry are you reading?  There is 2.4.0 FW out there already.

116 is not really a problem, we have facilities with 150+ devices without issue. We're reading 10 input registers (and writing occasionally to 5 of them) on each device. CPU hovers nicely around 0.80 when all devices are registered. Mind you, this is with a permanent MQTT connection Wink 

We haven't confirmed that 2.4.0 works fully with our software yet. Are there any fixes for modbus in this FW?
Reply
#4
If you downloda firmware package for 2.3.0 from se.com there is modbus.lump file.

2018.08.22-modbus.lmup - Patch for reading coils/discrete inputs bug
Reply
#5
For some TCP devices you need to enable persistent connection mode.
Reply


Forum Jump: