This forum uses cookies
This forum makes use of cookies to store your login information if you are registered, and your last visit if you are not. Cookies are small text documents stored on your computer; the cookies set by this forum can only be used on this website and pose no security risk. Cookies on this forum also track the specific topics you have read and when you last read them. Please confirm whether you accept or reject these cookies being set.

Using multiple devices on the same TP line
#1
I plan to have a spaceLYnk, a "Wiser for KNX" and an LM5 all connected to the same TP line (the main line 1.0.-). 
Everything works fine when one unit is connected (the spaceLYnk with lots of scripts), but when I attach the second (Wiser no scripts yet - just approximately 1000 GAs), lots of strange things happen (lights start blinking, scripts are not run, etc). I have a feeling that the system goes into some trashing mode.
Anything I need to adjust in terms of parameters? 
For instance, they all have the same "multicast" address. Is that OK?
I have checked that they have different IP addresses (DHCP), so no problem there.
They have TP-UART as mode.
One has KNX Individual address 1.0.240, the other has the default 15.15.250. Is the individual address used for anything?
Any other good tips?
Thanks in advance
Rgds
Christian
Reply
#2
Hi,

Apart from thinking why you want or need multiple controllers in the same line, you need to be sure not to create loops in the line. 

As you have all 3 controllers in the same TP line and connected to IP you have created 3 loops, a controller receives a telegram on TP and sends this to IP and the other 2 devices are receiving this on IP and sends it again to the TP bus, and again and again... so this is what you notice.

To avoid this you need to disable KNX IP features in the KNX settings on at least 2 of the 3 controllers, this way the IP telegrams are not received and sended on the KNX TP bus anymore. 

Normally you can have only one! KNX interface in a single TP line, so if you have any standard KNX IP interface / router already in the TP line you always need to disable KNX IP features in the controller.

BR,

Erwin
Reply
#3
Thank you so much for a switft answer. I will try this out later today and report back.

As to you question "why several devices on same TP line"....:
- spaceLYnk and Wiser are just an interim solution (I am migrating from an old SL to a new Wiser, so after completed migration SL will be shut off). However, this process takes time and to avoid downtime, I wanted to keep the SL up and running in parallel
- Wiser and LM is due to security. The LM is more hardened with respect to security as it contains functionality integrated with alarm, door locks, etc. The LM should therefore not be remotely accessible in any way (not even over VPN) whilst the Wiser has a full-blown external interface (to thermostats, lights, etc)
Regards
Christian
Reply
#4
Turning off KNX IP on all but one device worked. Thanks so much.



Sent from my iPhone using Tapatalk
Reply


Forum Jump: