This forum uses cookies
This forum makes use of cookies to store your login information if you are registered, and your last visit if you are not. Cookies are small text documents stored on your computer; the cookies set by this forum can only be used on this website and pose no security risk. Cookies on this forum also track the specific topics you have read and when you last read them. Please confirm whether you accept or reject these cookies being set.

Reactor remote CONN
#1
Hello

A question about LogiMachine Reactor, can I send SMS via GSM, can the GSM also be used for a remote connection to the LM?

Thank you


BR
Reply
#2
Reactor GSM has a built-in modem which can be used both for SMS and Internet access. If you want to access LM directly then you will need a real IP address from your provider but this not recommended. Alternatively you can use VPN which is more secure.
Reply
#3
(29.09.2020, 13:04)admin Wrote: Reactor GSM has a built-in modem which can be used both for SMS and Internet access. If you want to access LM directly then you will need a real IP address from your provider but this not recommended. Alternatively you can use VPN which is more secure.
Is possible to use VPN in visu via LUA script ?
I need a VPN Server ?

BR
Reply
#4
VPN can be configured from the UI. But you need a VPN server for it to work.
Reply
#5
Hi

Exist a free VPN server  to use , or need to setting my VPN OperVPN Server , my firewall not support OpenVPN.

BR
Reply
#6
Free VPN services do not allow client-to-client connections so you need your own OpenVPN server. We've also tried ZeroTier (https://www.zerotier.com/) which acts as a "virtual switch" allowing connections between remote devices without any extra configuration. It has a free option with up to 50 devices. But there's no UI for it on LM yet.
Reply
#7
(30.09.2020, 08:14)admin Wrote: Free VPN services do not allow client-to-client connections so you need your own OpenVPN server. We've also tried ZeroTier (https://www.zerotier.com/) which acts as a "virtual switch" allowing connections between remote devices without any extra configuration. It has a free option with up to 50 devices. But there's no UI for it on LM yet.
Hi

I have a Synology NAS , and inside is a VPNSever with OpenVPN support , i have onfigure it , and I have put the content of fiel ,ovpn in the LM se username e password .

For open connection is possible from lua , need add script ? Is possible have one example for script

thanks in advantage

BR
Reply
#8
Just configure OpenVPN from the UI, no need for any scripts.
You should add these lines to OpenVPN configuration entry:
Code:
pull-filter ignore "route-gateway"
pull-filter ignore "dhcp-option DNS"
This won't use VPN connection as the default gateway. Otherwise all connections from LM (like HTTP requests etc) will go through VPN. It will still allow to connect to LM via VPN.
Reply
#9
(30.09.2020, 09:45)admin Wrote: Just configure OpenVPN from the UI, no need for any scripts.
You should add these lines to OpenVPN configuration entry:
Code:
pull-filter ignore "route-gateway"
pull-filter ignore "dhcp-option DNS"
This won't use VPN connection as the default gateway. Otherwise all connections from LM (like HTTP requests etc) will go through VPN. It will still allow to connect to LM via VPN.
Hi 

I have add this in the configuration file (client.ovpn) is correct
Have you one example for me?

Code:
tls-client

remote 188.9.31.29 1194

pull
proto udp
script-security 2
reneg-sec 0
cipher AES-256-CBC
auth SHA512
auth-user-pass
<ca>
-----BEGIN CERTIFICATE-----
MIIDdTCCAl2gAwIBAgIJAMEEGqnVR2xrMA0GCSqGSIb3DQEBCwUAMFExCzAJBgNV
BAYTAlRXMQ8wDQYDVQQHDAZUYWlwZWkxFjAUBgNVBAoMDVN5bm9sb2d5IEluYy4x
GTAXBgNVBAMMEFN5bm9sb2d5IEluYy4gQ0EwHhcNMTYwNjI3MTAwMTU1WhcNMzYw
MzE0MTAwMTU1WjBRMQswCQYDVQQGEwJUVzEPMA0GA1UEBwwGVGFpcGVpMRYwFAYD
VQQKDA1TeW5vbG9neSBJbmMuMRkwFwYDVQQDDBBTeW5vbG9neSBJbmMuIENBMIIB
IjANBgkqhkiG9w0BAQEFAAOCAQ8AMIIBCgKCAQEAzLPBv1QnotlKNVUWbHcbvGGj
dEvjjkv7O8yEYmKOurpZfTdMUYR9x+s6Z+BNcohHK6R8IJVsf8mcDPtFhZDeAvD8
uPz7FectemYsZ5w5c47pIbRs6Iu3OtC6zXF2YZMiECViYlJvE6SMMCeNQe2KUKvR
aItmxPmVPgaYSjs0AJCZg2rDc6Z67qHa4dyAjZaqoMOgAJ/S39Yh7pAawEhsy7w4
GM22v12XGsuRI9EAG+ndqIsPpVG0VcRBWPIDPX1chmrjifjlL7PRS8QUBjiJYIxN
nTQmJ6vKZD07wGyV4ZztyfcUkhd1eOX/Nw8O8C9rYNKB3VTrhsBK7Gs0wC8JzQID
AQABo1AwTjAdBgNVHQ4EFgQUACHz421/vcP8TXlNbG4rSpM/xrYwHwYDVR0jBBgw
FoAUACHz421/vcP8TXlNbG4rSpM/xrYwDAYDVR0TBAUwAwEB/zANBgkqhkiG9w0B
AQsFAAOCAQEAqUe5CZLUkJXk0jrTaxrZYGgAs4AqTva+fWBEYHe1YFVwVhIBbe4N
fBm9W+9y3nEzzvZELJ4MU7rHUFXtWBqmnfG0BK1nlm1wweBh1B51ycDfWnri97f4
y8+cRR2zasx83sho6PBZADhnWpVDDePp3p6gfDrWNQxBQ4//Il+LUo0RjM832ooQ
1tkVA/W0tejiHU5z+GWNiu/tdnZAQhkAyFA4ZR6quO0Am6CFn9GWDsh3hjQQUIJj
d12uBUobvjBAoR1wqM70OI4Jv7DzyRk77BxXLuXVHOOGr7ou4KY8w0OYiEHm3rxh
Zqj3ewgBDTiy+5C2UYWxNAAVa26qFJwkSw==
-----END CERTIFICATE-----
</ca>

but i have this response from vpn status

Code:
Wed Sep 30 12:49:57 2020 SIGUSR1[soft,network-unreachable] received, process restarting
Wed Sep 30 12:49:57 2020 Network unreachable, restarting
Wed Sep 30 12:49:57 2020 write UDP: Network unreachable (code=101)
Wed Sep 30 12:49:57 2020 UDP link remote: [AF_INET]188.9.31.29:1194
Wed Sep 30 12:49:57 2020 UDP link local (bound): [AF_INET][undef]:1194
Wed Sep 30 12:49:57 2020 TCP/UDP: Preserving recently used remote address: [AF_INET]188.9.31.29:1194
Wed Sep 30 12:49:57 2020 WARNING: No server certificate verification method has been enabled. See http://openvpn.net/howto.html#mitm for more info.
Wed Sep 30 12:49:47 2020 SIGUSR1[soft,network-unreachable] received, process restarting
Wed Sep 30 12:49:47 2020 Network unreachable, restarting
Wed Sep 30 12:49:47 2020 write UDP: Network unreachable (code=101)
Wed Sep 30 12:49:47 2020 UDP link remote: [AF_INET]188.9.31.29:1194

where is the problem error 101 what is it?

BR
Reply
#10
This means that LM cannot reach the remote network. Check that you have a valid gateway in LM and that you can ping VPN server from LM (System config > Status > Network utilities > Ping).

Your config is not fully valid:
1. Replace auth-user-pass in your config with dev tun0
2. Don't forget to add two pull-filter lines I've mentioned before <ca> line
Reply
#11
(30.09.2020, 13:10)admin Wrote: This means that LM cannot reach the remote network. Check that you have a valid gateway in LM and that you can ping VPN server from LM (System config > Status > Network utilities > Ping).

Your config is not fully valid:
1. Replace auth-user-pass in your config with dev tun0
2. Don't forget to add two pull-filter lines I've mentioned before <ca> line
 OK now works

But now is not possible to reached the LM

IP for LM 192.168.0.101 not responding

IP LM witj OpenVPN 10.8.0.10 not responding

why ?
Reply
#12
You need to enable client-to-client option in VPN server configuration.
Reply


Forum Jump: