This forum uses cookies
This forum makes use of cookies to store your login information if you are registered, and your last visit if you are not. Cookies are small text documents stored on your computer; the cookies set by this forum can only be used on this website and pose no security risk. Cookies on this forum also track the specific topics you have read and when you last read them. Please confirm whether you accept or reject these cookies being set.

Restoring backup to newer firmware version
#1
I have a problem with a third party 'library' that prohibits me from upgrading the firmware on a couple of LM4.

When these system where installed, the developer himself installed the library. Some time later I tried to upgrade the LM4 to firmware version 20160714 and this resulted in the external library not functioning anymore. The developer had to make some modifications in order to get everything working again. I have no idea what the problem really was...

Since then I left these LM4 alone and decided not to try to upgrade the firmware.

However, some functionality stopped working with the old firmware (eg. Telegram messages, for which I had to implement a workaround with another server) and many new features are available with the newer firmware...

Lately both of the LM4 ran into a read-only SD card and I took the opportunity to try to upgrade to the 2020.07 firmware.
After cloning the SD card I updated the system and that appeared to have worked, but the extra tabs that the external library provides were gone... I redid everything and now am back on 20160714...

The developer seems to have vanished...

I wonder if I could start from scratch with the recovery image, install 2020.07 firmware and then restore from a 20160714 backup? Would that make any difference?
Reply
#2
Installing from scratch probably won't change anything. Backups are always forward compatible which means that you can restore a backup from older firmware on a device running a newer firmware.
Do you have a package for this library? Can you send it to me? Might be possible to fix it to run on 2020 FW or newer.
Reply


Forum Jump: