This forum uses cookies
This forum makes use of cookies to store your login information if you are registered, and your last visit if you are not. Cookies are small text documents stored on your computer; the cookies set by this forum can only be used on this website and pose no security risk. Cookies on this forum also track the specific topics you have read and when you last read them. Please confirm whether you accept or reject these cookies being set.

Zigbee gateway integration
#21
I really look forward to implement zigbee gateway on LM
Is there the possibility to be included in the Beta test on la LM5 lite (mx6)
Which dongle do I eventually Need?
I'm actually running zigbee2mqtt with a conbee II which I understand Is not supporter, but I do have a zzh (cr2652r) of Is supported

Thanks
Regards
Marco
Reply
#22
To avoid any mismatch in HW and SW we prefer that any tester will purchase dongle from us. If you want contact our sales. Once you have it ask for software again.
------------------------------
Ctrl+F5
Reply
#23
Updated ZigBee app has been published in the app store. It is recommend to reboot LM after installation.
Reply
#24
(21.05.2021, 13:12)admin Wrote: Updated ZigBee app has been published in the app store. It is recommend to reboot LM after installation.

Thanks a lot!

Xiaomi Aqara smart plug now shows 'Active power (floating point)' object, next to on/off object.

However the Xiaomi Aqara Waterleak Sensor still hasn't an object attached, is this correct?
Reply
#25
Can you provide a screenshot of the device list and device info for the leak sensor?
Reply
#26
(24.05.2021, 09:45)admin Wrote: Can you provide a screenshot of the device list and device info for the leak sensor?


Sure, here it is. Screenshot of device list, device information, monitor and log.
The monitor and log shows what happend when I closed and released the circuit on the water leak sensor.

Attached Files Thumbnail(s)
   
.txt   log_zigbee.txt (Size: 6.11 KB / Downloads: 4)
Reply
#27
Do all water leak sensors that you've paired have the same cluster list?
Reply
#28
(29.05.2021, 09:05)admin Wrote: Do all water leak sensors that you've paired have the same cluster list?

Yes, I think so. I've added a screenshot of all 3 sensors aswell as the logs of all 3 sensors when button pressed and when contact closed.

Attached Files Thumbnail(s)
   
.txt   log_zigbee2.txt (Size: 15.83 KB / Downloads: 2)
Reply
#29
The app has been updated. Check if you can map your water leak sensors to objects now.
Reply
#30
Thanks for the update

Aqara Water leak sensor, model SJCGQ11LM, LUMI
  • Updated the app
  • water leak sensor now has 3 entries 'detection, tamper, low battery'
  • Tested and working, generates a '1' when contacts are closed and returns to '0' when contacts are open.
  • Not tested: tamper and battery level.
Aqara Smart Plug, model SP-EUC01, LUMI
  • shows 'Active power (floating point)' object in Zigbee app
  • value is not shown in objects tab, object 8/1/10 (14.4 byte floating point), stays at 0.000
  • when reading status in 'control and status' in Zigbee app the value is shown correctly
Reply
#31
Try resetting the plug and pairing it again. You've probably paired it before the power reading was implemented so the required configuration requests were not sent.
Reply
#32
That did the trick. Thanks!

However the previous associated object with 14.4 byte floating point showed a wrong value at first.
I had to set the object to something else and then set it back to 14.4 byte floating point to get the correct value.
Now everything is working fine.
Reply
#33
Hi.
Bought 4 pcs of Develco SPLZB-131 Schuko plugs with power metering.
I successfully pair these, but they won't operate on/off. and no power report to object is happening.

Device information;

Device type: Router
Power source: Mains
Receive when idle: Yes

Endpoint 2
Profile: 260
Input clusters:
- Basic (0)
- SeMetering (1794)
- Identify (3)
- Alarms (9)
- HaElectricalMeasurement (2820)
- OnOff (6)
- Groups (4)
- Scenes (5)
- DeviceTempCfg (2)
Output clusters:
- Basic (0)
- Ota (25)
- Time (10)
- Identify (3)
- MsOccupancySensing (1030)

Endpoint 1
Profile: 49353
Input clusters:
- Scenes (5)
- OnOff (6)


I also bought a namron zigbee 4 channel remote.
The remote only work for one group (all on/off/dim?),all buttons report to the same object, on off or dimm
Is there a way to utilize the group function on these remotes for controlling objects in LM without this direct accosiation between remote and other zigbee device in network. I have seen the same on the Phillips Hue Dimmer switch.
Also the scene buttons dont show up as a resource, not able to make any use for them.

Device information;

Device type: End device
Power source: Battery
Receive when idle: No

Endpoint 1
Profile: 260
Input clusters:
- Basic (0)
- PowerCfg (1)
- Identify (3)
- HaDiagnostic (2821)
Output clusters:
- Identify (3)
- Groups (4)
- Scenes (5)
- OnOff (6)
- LevelCtrl (8)
- Ota (25)
- LightingColorCtrl (768)
- LightLink (4096)

Endpoint 2
Profile: 260
Input clusters:
- Basic (0)
- PowerCfg (1)
- Identify (3)
- HaDiagnostic (2821)
Output clusters:
- Identify (3)
- Groups (4)
- Scenes (5)
- OnOff (6)
- LevelCtrl (8)
- Ota (25)
- LightingColorCtrl (768)
- LightLink (4096)

Endpoint 3
Profile: 260
Input clusters:
- Basic (0)
- PowerCfg (1)
- Identify (3)
- HaDiagnostic (2821)
Output clusters:
- Identify (3)
- Groups (4)
- Scenes (5)
- OnOff (6)
- LevelCtrl (8)
- Ota (25)
- LightingColorCtrl (768)
- LightLink (4096)

Endpoint 4
Profile: 260
Input clusters:
- Basic (0)
- PowerCfg (1)
- Identify (3)
- HaDiagnostic (2821)
Output clusters:
- Identify (3)
- Groups (4)
- Scenes (5)
- OnOff (6)
- LevelCtrl (8)
- Ota (25)
- LightingColorCtrl (768)
- LightLink (4096)
Karl Fredrik

New buildt house in Tromsø, Norway
KNX, DALI, CANx, modbus
Logic Machine
Waterheating, Ventilation, door automation (wired), firealarm, and more to come. #Smarthomenewbuild
Reply
#34
Both devices can be integrated but keep in mind that the current dongle cannot handle more than 15 ZigBee devices connected to it. Connecting more than 15 can brick the dongle and it must be re-flashed using an external programming device. We are working on an improved ZigBee-USB interface with an external antenna. It's based on a newer chip and can handle a lot more connections.
Reply
#35
(21.06.2021, 06:36)admin Wrote: Both devices can be integrated but keep in mind that the current dongle cannot handle more than 15 ZigBee devices connected to it. Connecting more than 15 can brick the dongle and it must be re-flashed using an external programming device. We are working on an improved ZigBee-USB interface with an external antenna. It's based on a newer chip and can handle a lot more connections.

I only have 11 devices in my system so I think I'm ok.
The namron remote i mentioned shall also support touchlink to devices via group, and i found that the only "normal" way of assigning the buttons on the remote is direct pairing to devices alredy in the network. But I have trouble to find out how to initiate touchlink commissioning from LM. Tried the pair function per unit, without any luck. 

The schuko plugs is still unsolved also. 
I guess its misses some profile info that have to be implemented in the zigbee app. Is there a way for adding this myself, or is the development not ready for this step? (roadmap in zigbee development?) 
I'm happy to test and help out in testing at my system. I'm also intreressted in new usb with external antenna, as my LM is installed in the steel cabinet alongside my fuses in the basement, with a lot of concrete around. I therefore use schuko plugs as repeaters to help the zigbee mesh network.
Karl Fredrik

New buildt house in Tromsø, Norway
KNX, DALI, CANx, modbus
Logic Machine
Waterheating, Ventilation, door automation (wired), firealarm, and more to come. #Smarthomenewbuild
Reply
#36
Currently it's not possible to make custom user profiles. We might implement this later though.
The direct pairing is for stand-alone mode without a gateway as devicea will form their own network for this. We will implement ZigBee groups later. Using groups you can control several lamps using a single switch and this connection will also work even if the gateway is offline.
Reply
#37
Is it possible to add a profile for a Mi-Light / Miboxer FUT039Z rgb+cct led controller.
link (https://www.milight-nederland.nl/nl/prod...zigbee-30/)

I've attached the log for this device.

It currently picks up this profile but this lacks control over the different rgb+cct channels:
Code:
Device type: Router
Power source: Mains
Receive when idle: Yes

Endpoint 1
Profile: 260
Input clusters:
- Basic (0)
- Identify (3)
- Groups (4)
- Scenes (5)
- OnOff (6)
- LightLink (4096)
- LevelCtrl (8)
- LightingColorCtrl (768)
- 61184
Output clusters:
- Ota (25)
- Time (10)

Endpoint 242
Profile: 41440
Output clusters:
- GreenPwr (33)

Thanks in advance!

Attached Files
.txt   log_zigbee_mi-light_FUT039Z.txt (Size: 16.61 KB / Downloads: 4)
Reply
#38
Is it reported as "Mi-Light - Miboxer FUT039Z" in the app or differently? The profile uses device "manufacturer - model" pair to identify the device.
Reply
#39
(07.07.2021, 11:50)admin Wrote: Is it reported as "Mi-Light - Miboxer FUT039Z" in the app or differently? The profile uses device "manufacturer - model" pair to identify the device.


No it is not reported in the App as 'Mi-Light...', see screenshot below, the second line (F5D4).

   




The first line is a Single Color Led controller from the same brand model FUT036Z and has gotten the correct profile.

I searched a little further and if I'm correct TS0505B is the device model in the app?
This should be correct for a rgb+cct device, though the configuration window has no fields for those rgb+cct values.
Reply
#40
(07.07.2021, 11:50)admin Wrote: Is it reported as "Mi-Light - Miboxer FUT039Z" in the app or differently? The profile uses device "manufacturer - model" pair to identify the device.

Is there a status update on this issue?
Has this to do with my configuration or will this be solved with a future update?

Thanks in advance!
Reply


Forum Jump: