This forum uses cookies
This forum makes use of cookies to store your login information if you are registered, and your last visit if you are not. Cookies are small text documents stored on your computer; the cookies set by this forum can only be used on this website and pose no security risk. Cookies on this forum also track the specific topics you have read and when you last read them. Please confirm that you accept these cookies being set.

Device disappearing at random with a line scan

I have a Wiser for KNX with a strange problem:

basically we have 18 devices all in a line (no coupler), everything was powered but with a line scan we can't see pretty much any device at all...sometimes 2 or 3 of them (and never the same devices) popping out and then disappear again if we run another line scan.

This is probably a bus problem, we tried to remove some devices and pretty much anything changed.

On the error log I have

I deleted the errors but there were more and they keeps repeating.

Locally, if I move for example a setpoint, everything works fine...the system turn on all the other devices as if the bus have no problems.

Huh I'm really confused...
Did you check in ETS monitor, check what happend on the KNX bus traffic?
maybe to much traffic on the KNX bus why LM got to heat?
I checked, it seems like there's no traffic at all, only a few messages on the bus.

Could it be a short circuit on a branch or something like that?
Have you measured bus voltage and current? If the current consumption is high then maybe one of the devices if faulty.
Another possibility is a loose cable or an incorrect connection somewhere.
I'm not at the site right now but there was one of the electricians yesterday, he measured 29 V on the bus but I don't know if he measured the consumption.
Thanks for the tip though, I'll check it ASAP.
I suspect that there is a faulty connection somewhere, maybe a rat or something ruined the bus cable, but it's really hard to find.
Another possibility is that the power supply or the webserver are faulty, but it sounds really strange because I know that they worked at the time I programmed the system.
Ok, that's strange...

We changed webserver with a new one, we changed BUS power supply, we tried to undo and redo the branch that seems to cause problems...nothing worked.

The situation is:

If we try to send commands the devices respond, but very often we lose messages.

Could it be the cable length? But it's under 350m in total...

The only thing that we observed is that if we disconnect phisically the three devices connected to that branch everything seems to work fine, if we connect those devices before the branch everything works fine but if we connect even one of those devices on the branch we have problems...

That situation is driving me mad! Angry Sad
Maybe add a repeater and new psu for this branch.
Yes, that's what we've done just a minute ago and it seems to work.

The question is: what could possibly cause that kind of behaviour? I can't figure it out...

Can't be a short circuit because power supply and all the devices seems to work.
Can't be cable length because, according to what the electrician said (but we estimated the same thing), it is under 350 m.
There is a star with 5 branches but only one seems to cause problems, we changed the bus cable and we tried even with a zipline minimizing the didn't work so can't be the cable integrity.
Can't be webserver or PSU because we changed them.
Can't be number of devices because there are only 19 including the repeater.

This is really insane for me, I feel like a ghosthunter...
Star topology with long cable length can cause issues because the signal is reflected on each branch. As Daniel said adding a line coupler can help.
If you have an oscilloscope you can check the how the signal looks on all branch ends.
It sure helped adding a line coupler as a repeater, but it's really really strange because we had bigger installations with star topology and no problem at all.

Maybe some field singularity but who knows.

Thank you all for helping though!

Forum Jump: