This forum uses cookies
This forum makes use of cookies to store your login information if you are registered, and your last visit if you are not. Cookies are small text documents stored on your computer; the cookies set by this forum can only be used on this website and pose no security risk. Cookies on this forum also track the specific topics you have read and when you last read them. Please confirm whether you accept or reject these cookies being set.

Zwave - Fibaro Motion Sensor
#61
thanks for your reports! Responsible developer for ZWave was absent for couple of days, I asked him to look into your points and fix the issues. So hope to have updated release soon Smile
Reply
#62
Many thanks.
Reply
#63
Hello, is there already more information for the zwave "problems".

I need to close some walls with Double relay switch build-in. But i need to know if the problem that only 1 relay is found in the LM4 is a "software" related bug and automatically solved or do i need to re-add the double relay switch to the LM4 (and then i need to have access to the B-button).
Reply
#64
Hi! can you please try to remove/add this device and provide remote access to us? (please send in private message)
Reply
#65
1 Is the Fibaro Swipe supported? FGGC-001 ( It is supported by openzwave: https://github.com/OpenZWave/open-zwave/...ggc001.xml )

2 I have some trouble with the Greenwave PowerNode 6: only 1 switch output is displayed in the output parameters (same problem as before with the 2 relay switch)

Can you please fix this?
Reply
#66
all known bugs have been fixed, try upgrading to the latest ZWave app from store.
Reply
#67
Edgars, I see below statement on Fibaro's website regarding the Fibaro Door/Window Sensor:

"Wireless update - The FIBARO Door / Window Sensor has been designed to receive wireless software updates. Every upgrade of the device takes place seamlessly and without any action. Full automation of the software update is done with comfort and safety guaranteed by the Fibaro team."

I was wondering if your team has seen this and might consider integrating such a feature inside the LM, especially for all Fibaro sensors. 
I believe a closer collaboration with Fibaro team in Poland will help, if it's part of your roadmap.

Can you confirm that all Fibaro sensors are working now? I was considering to purchase this door/windows sensor sensor and test it with my LM4 and Z-Wave.Me (ZME-UZB1 USB stick).
Reply
#68
I got my new LM5 today, and I wanted to try out Z-Wave, but I can't find the app in the app store.
My version on the LM5 is 20160721.
Do I have to activate something before I can find the Z-Wave app?
Reply
#69
It's not yet published for LM with new CPU. We'll do some quick tests today and update the store.
Reply
#70
is it released for the reactor V3?
Reply
#71
Yes, but you need to install RC firmware to get it.
Reply
#72
Hi,

I wanted to do some testing with z-wave devices and bought an Aeon Labs Z-stick Series 2 USB dongle.

Installed the app on LM4 with firmware 20160714.

Installed the usb dongle and started the daemon: the screen goes black for a few seconds and then returns with the daemon status: stopped.
No device information is displayed.
Clicking on Device Configuration returns me to the home screen.

Is there anything else I need to do to get this working?

Thanks.
Reply
#73
Hi,

I wanted to make sure that my dongle was working, so I first plugged it in my desktop machine running Fedora 25: it was detected as a cp210x device.

As I had a raspberry lying around I then installed a software called Home Assistant on it. Plugged in the dongle and it was recognized and I could pair an Aeotec sensor with it.

So now I know the hardware is OK.

After that I gave it one more try on my LM, but with the same result...  [Image: sad.png]
Reply
#74
You can check it's properlly detected in LM.

For this go in Configuration / System / status / system logs.

Then plug you USB stick.
You should see couples of lines that look like this:

Code:
cdc_acm 1-1:1.0: ttyACM*: USB ACM device
usb 1-1: SerialNumber: xxxxxxxxxx
usb 1-1: Manufacturer: xxxxxx
usb 1-1: Product: xxxxxxxxx
usb 1-1: New USB device strings: Mfr=x, Product=X, SerialNumber=x
usb 1-1: New USB device found, idVendor=xxxx, idProduct=xxxx
usb 1-1: new full-speed USB device number x using ci_hdrc

If it does, then open open status / system status, and click on serial port.
You should see a line that corresponds to the ttyACM from the syslog.

If you see the line. Means you stick is recognize by the system. and the issue comme probably from the widget.
Did you try to uninstall and reinstall the widget?
Reply
#75
The dongle is detected by LM.

System log:

Code:
Feb 23 22:33:58 Logic Machine kern.info kernel: [442381.341259] usb 1-1: cp210x converter now attached to ttyUSB0
Feb 23 22:33:58 Logic Machine kern.info kernel: [442381.340399] cp210x 1-1:1.0: cp210x converter detected
Feb 23 22:33:58 Logic Machine kern.info kernel: [442381.330921] usb 1-1: SerialNumber: 0001
Feb 23 22:33:58 Logic Machine kern.info kernel: [442381.330891] usb 1-1: Manufacturer: Silicon Labs
Feb 23 22:33:58 Logic Machine kern.info kernel: [442381.330859] usb 1-1: Product: CP2102 USB to UART Bridge Controller
Feb 23 22:33:58 Logic Machine kern.info kernel: [442381.330818] usb 1-1: New USB device strings: Mfr=1, Product=2, SerialNumber=3
Feb 23 22:33:58 Logic Machine kern.info kernel: [442381.330752] usb 1-1: New USB device found, idVendor=10c4, idProduct=ea60
Feb 23 22:33:58 Logic Machine kern.info kernel: [442381.192813] usb 1-1: new full-speed USB device number 5 using


Serial ports:

Code:
/dev/ttyUSB0   Silicon Labs - CP2102 USB to UART Bridge Controller


Uninstalled and re-installed the app.
Started the daemon, no result... [Image: sad.png]

No messages in the system log.
Is there any other log that might show what is going on?
Reply
#76
On the config page of Z-wave widget,

does the port textfield is filled with /dev/ttyUSB0 ?
Reply
#77
When I start the app, the Daemon Status is 'Stopped', Status is '/' and all other fields are blank.
Maybe I should reboot the LM?
Reply
#78
Yes, try to restart the LM. Did you try to hit save before 'start deamon'?
I have the same behaviour on a LM without zwave dongle on it.
Reply
#79
I think daemon works only with /dev/ttyACM0, as a trick you can add this to LM init script:
Code:
os.execute('ln -sf /dev/ttyUSB0 /dev/ttyACM0')
Reply
#80
That was indeed the case!

Now I have a correct screen.

Up to do some testing with Z-wave...

Thanks.
Reply


Forum Jump: