This forum uses cookies
This forum makes use of cookies to store your login information if you are registered, and your last visit if you are not. Cookies are small text documents stored on your computer; the cookies set by this forum can only be used on this website and pose no security risk. Cookies on this forum also track the specific topics you have read and when you last read them. Please confirm whether you accept or reject these cookies being set.

Ekey finger scanner
Hello, I tried to configure Ekey finger scanner using an example you have but with no luck since the download link for the package wasn't found at all. Could you please re-upload the package?
Which firmware and hardware are you using?
20170620 is the current firmware version of the "Logic Machine 5 Re:actor"
You can find links to extra packages here:
Ekey scanners must be connected to the second RS485 port.
Thank you very much!

I imported the package luaekey_0.1_imx6.ipk which I found in the extra packages link you sent me, it responded with "Done.", then I rebooted LM but I still don't see the "Ekey" in the main menu of LM (where Scenes, Trend Logs etc. are).
You also need genohm-scada-ekey package
Works, thank you!
Wouldn't be me if I didn't need the whole walkthrough..

I connected the RS485 from the scanner into the second logic machine RS485 port since it has two. Now, the scanner should have steady blue light but instead it has steady blue light for like 2-3 seconds and then it blinks orange few times. Do I need to configure something else? Like open the port or something? If yes how exactly?
Try this updated package:

This can happen if you have several scanners due to collisions during initial identification. But since you have only one you should also check the wiring.
(29.06.2018, 08:09)admin Wrote: Try this updated package:

This can happen if you have several scanners due to collisions during initial identification. But since you have only one you should also check the wiring
Checked the wiring, should be fine.. 
RS485 A -> Yellow (2nd pin)
RS485 B -> Green (1st pin)
nothing in gnd.

Keeps blinking orange after 3 seconds of blue steady light. Just tried to change different cables in hope it might be it, is there any way I can refresh it so it looks for the scanner or is it automatic since in "Ekey -> Logs" it shows "Error: No modules found" but the timestamp is from 40 minutes ago.

Also, few weeks ago I tried something with this port where I used this script:
-- open port on first call
if not port then
port ='/dev/RS485-1', { baudrate = 4800, parity = 'odd', duplex = 'half', databits = 8, stopbits = 1 })
-- port ready
if port then
-- read one byte
char = port:read(1, 1)
-- send back if read succeeded
if char then

grp.write('30/1/1', char)
Can this be an issue?

EDIT: Checked operating instructions, there it says that when orange light is blinking I should check the wiring or commission the device. Wiring seems fine, but how do I commission it. I only have the scanner, I don't have the keypad. Also, on the screenshot in the ekey scanner tutorial example here on the site, you have a picture where there is "Rescan / Search" button in Scanners tab. I don't have that.
I'm suspecting it might be because of the script I tried, since now I don't even get new log in Ekey -> Logs when I reboot LM. Is there a way to put it to default state as it was before I used the script?

EDIT/SOLUTION: All right, tried to reach Ekey support in my country but they pretty much ignored me at this point so I reached to international support in Austria, where they told me that I need module finger scanner, not Ekey Home as I have. That means it won't work like that.

Forum Jump: