This forum uses cookies
This forum makes use of cookies to store your login information if you are registered, and your last visit if you are not. Cookies are small text documents stored on your computer; the cookies set by this forum can only be used on this website and pose no security risk. Cookies on this forum also track the specific topics you have read and when you last read them. Please confirm whether you accept or reject these cookies being set.

Mosaic was deleted

I finally got into migrating from Mosaic 2.0 to Mosaic 3.0 since it looks amazing and has a lot of great features. I spent more than whole day working on it while still having Mosaic 2.0 available. Now that I have finished it, I decided that there is no need to have old Mosaic 2.0 installed, so I deleted it. Immediately after I have deleted Mosaic 2.0 I noticed that I haven't updated Mosaic 3.0 to 2019 version yet, I had it at version 2018.... something.. It was the one with the icon same as Mosaic 2.0. So I have updated it. After updating I tried it to see the updates but there is nothing I have created! Seems like everything got deleted somehow. How is this possible? Is there a way to retrieve it? Now I have blank Mosaic 3.0 app and no Mosaic 2.0 since I deleted it. 

Please could you help me?

EDIT: I managed to install Mosaic 2.0 back, it has all the old configuration in it. Still haven't solved Mosaic 3.0 with all the work I have put into it. Any ideas?
It might be that the config key has changed. Run this script and post the results:
keys = storage.keys()
I ran the script you sent me. This appeared in Logs:

* table:
 * string: mosaic30-beta:cloud_user:0
 * string: fbeditor:1:diagrams
 * string: PID:Event for Ventilator - Kupelna - Timer (32/1/13)
 * string: mosaic:config:0
 * string: doxsw:alexa:devices2
 * string: central_timer
 * string: CurrLang
 * string: mosaic30-beta:config:0
 * string: mosaic:cloud:0
 * string: doxsw:mobile:android:devices
 * string: mosaic:cloud_user:0
 * string: mosaic30:config:0
Try updating Mosaic 3.0 now and see if it works. If it does not then please send a me backup from your device via PM.
Updated to newest 3.0 again, seems like everything is back and working! Thank you very much for such a quick fix.

Forum Jump: