This forum uses cookies
This forum makes use of cookies to store your login information if you are registered, and your last visit if you are not. Cookies are small text documents stored on your computer; the cookies set by this forum can only be used on this website and pose no security risk. Cookies on this forum also track the specific topics you have read and when you last read them. Please confirm that you accept these cookies being set.

DALI PROBLEM
#41
(11.12.2020, 10:08)Daniel. Wrote: If you still have the tx error then it is most likely broken interface.
Just to clarify, the partial scan is a scan which will find only devices which have no short address. If a ballast was already used elsewhere and programmed partial scan will not find it.  DALI app for canX dali has more options for this.

Yes, I understand the partial scan, but doing a full search already assigns the short addresses to the ballasts again.

I'll do the test by substituting the LM for the one on the way.

The CANx gateways are much better, it even gives us states and it is a great work that saves. If I could replace the Logic M. with a CANX one and not have to look for the ballasts again it would be great, but this I understand that it cannot be done.
Reply
#42
This LM internal interface can use canX dali app but only this one LM
https://openrb.com/logicmachine5-knx-canx-dali
------------------------------
Ctrl+F5
Reply
#43
Hello, I have finally been able to do the search with a new LM and now the search works.

What can I do with my faulty equipment? I'm going to test it in my test shop and reset it to factory settings in the hope of getting it back.

By the way, I am trying to regulate a Mean Well ballast and it is not possible to lower it from 63%. Is it a ballast problem or is it LM?
Reply
#44
Check minimum dimming value, it is parameter of the ballast, If you can change it lower then you will be able to go lower.
------------------------------
Ctrl+F5
Reply
#45
This is probably a hardware issue that factory reset won't solve. You can send your device to us for repairs.
Reply
#46
(15.12.2020, 15:42)Daniel. Wrote: Check minimum dimming value, it is parameter of the ballast, If you can change it lower then you will be able to go lower.
Hello Daniel, I understand that this parameter is not generated from LM, it is something internal to the ballast. or am I wrong? I have a Mean Well ELG-240H-24B, with the naked eye I can't do anything to it.
Reply
#47
There are two minimums - physical and user-defined. User-defined cannot be lower than physical. You can use querymin/queryphysicalmin to get both minimum values. CANx-DALI has this visible/configurable through UI.
Reply
#48
(16.12.2020, 07:58)admin Wrote: There are two minimums - physical and user-defined. User-defined cannot be lower than physical. You can use querymin/queryphysicalmin to get both minimum values. CANx-DALI has this visible/configurable through UI.

Hi Admin,

in the CAN X gateway I can see that minimum physical value that is equal to 161, but it does not let me download it from there. My led barely dims. If I want to take it to a value lower than 10%, what should I do?
Reply
#49
This means that the ballast cannot produce a value lower than 161. Nothing you can do apart from using a different ballast.
Reply
#50
(19.06.2019, 09:37)admin Wrote: DALI has configurable levels for SYSTEM FAILURE and POWER ON states. If this level is set to 255 (MASK) then SYSTEM FAILURE should be ignored and POWER ON state should be equal to last light level.

You can change these levels via a script (in this example on all ballasts on first internal DALI bus):
Code:
require('user.dali')
value = 0 -- from 0 to 255

dalicmd('internal', 'setdtr', { addrtype = 'broadcast', value = value })
dalicmd('internal', 'storepoweron', { addrtype = 'broadcast' })

value = 0 -- from 0 to 255

dalicmd('internal', 'setdtr', { addrtype = 'broadcast', value = value })
dalicmd('internal', 'storesystemfailure', { addrtype = 'broadcast' })

Hello Admin 
I have the same issue and the script solve the issue for the dimmable dali driver
but I have DT8 RGBW driver that in power failure go to a specific color (last color used) not to the last on/off state
Reply
#51
Try setting all RGBWAF channel value to 255 before executing storepoweron/storesystemfailure. You need to modify the setRGBWAF function because it clamps the maximum value to 254 using math.min.
Reply
#52
Hi, 

after successful upgrade my LM4 to the latest firmware, I noticed that all scripts with dalicmd failed to run. It looks like user.dali script is empty. Can I get user.dali script?
Thanks
Reply
#53
Try importing this to libraries

Attached Files
.gz   Libraries-LogicMachine-2021.11.18-14.19.tar.gz (Size: 428 bytes / Downloads: 5)
------------------------------
Ctrl+F5
Reply
#54
(18.11.2021, 14:20)Daniel Wrote: Try importing this to libraries

Thanks. Still getting:
User script:23: attempt to index global 'res' (a nil value)
stack traceback:
User script:23: in main chunk

at:
res = dalicmd('internal', 'queryactual', { addrtype = 'short', address = 3 })  --buvo 1

IT WAS working fine before the firmware update. Any ideas?

thanks a lot
Reply
#55
Send me your backup. will check if this is your LM or the firmware. Which fw?
------------------------------
Ctrl+F5
Reply
#56
(18.11.2021, 16:53)Daniel Wrote: Send me your backup. will check if this is your LM or the firmware. Which fw?

I send you a PM. thanks
Reply
#57
(18.11.2021, 17:20)puntukas Wrote:
(18.11.2021, 16:53)Daniel Wrote: Send me your backup. will check if this is your LM or the firmware. Which fw?

I send you a PM. thanks

Hi, I have the same problem after replacing SD card and upgrading to latest fw. Did you find a solution?

Best regards 
Eilert Bjerkan
HW: LM5 M4 I.MX6
Reply
#58
Here the problem was that the mapping was already lost before doing the flashing. If you lost library just reboot LM and it will be restored.
------------------------------
Ctrl+F5
Reply


Forum Jump: