This forum uses cookies
This forum makes use of cookies to store your login information if you are registered, and your last visit if you are not. Cookies are small text documents stored on your computer; the cookies set by this forum can only be used on this website and pose no security risk. Cookies on this forum also track the specific topics you have read and when you last read them. Please confirm whether you accept or reject these cookies being set.

ekey fsx App
#21
(22.04.2021, 13:19)agris Wrote: On the picture it looks like the termination resistor on the AP scanner is swithed ON. This scanner is placed in the middle of the serial line.  Because the LM port is not terminated, then both scanners in short line distances must be set in OFF position.

That makes sense, but still nothing. The DIP switch has "ON" and "1" labels. For me as a developer these both mean ON. Big Grin 
I have wired the two scanners in a daisy-chain topology, not star topology.

P.S. I just tried with only one scanner, both the DIP switch to ON and OFF positions. On daemon start the orange blinking LED becomes steady blue for couple of seconds and then orange blinking LED again. There's some communication, but something is wrong.
Reply
#22
(22.04.2021, 11:36)Daniel. Wrote: You can use this script to check if RS485 works correctly
https://forum.logicmachine.net/showthrea...9#pid13139
Make sure nothing else is using the it.  It could be enabled in modbus/Dali or in some script.

I ran the test between RS485-1 and RS485-2 - said it's OK. 
Reply
#23
I'm thinking GND now. I haven't connected the GND pin of the LM RS485. Can you please suggest me to what should I connect it?
Reply
#24
From the photos it looks like you are using the same power supply for both scanners and LM. In this case GND is already common.
Some time ago I've tested LM with around 10 scanners connected and there were some issues with the communication. Turns out that scanners have RS485 line polarization resistors which should only be present on master device. Removing these resistors from LM helped but it's not a viable solution.
Reply
#25
The actual problem cause: all database tables from this app 'ekey_*' are missing in the scada.db file. After the new app version was installed, the app worked, scanners are found, but after LM restart the same problem. Are non native db tables automatically deleted in the new LM software versions?  Or is it the memory card problem?
Reply
#26
LM does not delete any custom tables from the DB. If the card is in read-only state then the app will be missing or have an older version after a reboot.
Reply
#27
(23.04.2021, 08:07)admin Wrote: LM does not delete any custom tables from the DB. If the card is in read-only state then the app will be missing or have an older version after a reboot.

Is the card used for file storage only, or OS and system files are there too? I mean, can I easily replace the card with another one and check if the problem is bad card?
Reply
#28
Card stores everything except for LM models with an additional small on-board storage for databases and trends. You can easily replace the card, but you need to install recovery firmware on it first. See this guide: https://openrb.com/reflash-logicmachine3...-software/
Reply
#29
The problem occurs when after successful scanners initial registration into db table the LM was powered off without Restart or Shutdown commands before the LM data base was synchronized. When LM is started again the APP read the previous correctly saved storage variables and then decides that db tables exist and don't search scanners again.
The solution, in this case, is - uninstall the app, delete storage variables, and install ekey FSX app again.
I will look how into the next version to resolve this problem.
Reply
#30
App feature request - access control calendar & control by scripts.

Imagine you have a cleaning lady and you give her access rights to particular scanner only during a given time frame at particular days in the week. Would be awesome to have such access control using a weekly calendar UI in the "Rights" tab. Instead of a simple checkbox, I imagine to have a button that opens a weekly calendar UI like in the attached screenshot (this is the Ubiquity WiFi scheduler UI).

Also, would be awesome to expose function calls for scripts that give and take access rights per user/scanner pair. This way complex custom logics become possible.

Attached Files Image(s)
   
Reply


Forum Jump: