This forum uses cookies
This forum makes use of cookies to store your login information if you are registered, and your last visit if you are not. Cookies are small text documents stored on your computer; the cookies set by this forum can only be used on this website and pose no security risk. Cookies on this forum also track the specific topics you have read and when you last read them. Please confirm whether you accept or reject these cookies being set.

Nano Temp Inveo - Temperature Sensor
#1
Preface:

Manual:
http://download.inveo.com.pl/manual/nano...ual_en.pdf

Module:
https://www.tme.eu/at/en/details/nano-te...nano-temp/

Note: I try out several third-party sensors, but only the original Inveo sensors are working.

Sensors:
https://www.tme.eu/at/en/details/sensor-...nveo/ds-1/
https://www.tme.eu/at/en/details/sensor-...nveo/ds-5/
https://www.tme.eu/at/en/details/sensor-...veo/ds-10/

Question:

By the following .jons i get the output of 231°C (since it`s x 10 in accordance to the Manual)

{
  "manufacturer": "Hugo",
  "description": "Nano_Temp_Inveo_V1",
  "mapping": [
    { "name": "Temperatur", "bus_datatype": "int16", "datatype": "int16", "type": "register", "address": 4003, "units": "°C" }
  ]
}


But if i do this, i get the output of 23°C

{
  "manufacturer": "Hugo",
  "description": "Nano_Temp_Inveo_V2",
  "mapping": [
    { "name": "Temperatur", "bus_datatype": "int16", "datatype": "int16", "type": "register", "address": 4003, "value_multiplier": 0.1, "units": "°C" }
  ]
}

How i get the output 23,1°C?
Reply
#2
You have the wrong bus datatype, you need to use 2 byte float..
Reply
#3
Thanks, it's 23.1 ° C now.

{
"manufacturer": "Hugo",
"description": "Nano_Temp_Inveo_V2",
"mapping": [
{ "name": "Temperatur", "bus_datatype": "float16", "datatype": "int16", "type": "register", "address": 4003, "value_multiplier": 0.1, "units": "°C" }
]
}
Reply


Forum Jump: