This forum uses cookies
This forum makes use of cookies to store your login information if you are registered, and your last visit if you are not. Cookies are small text documents stored on your computer; the cookies set by this forum can only be used on this website and pose no security risk. Cookies on this forum also track the specific topics you have read and when you last read them. Please confirm whether you accept or reject these cookies being set.

[OLD] LogicMachine firmware 2016.07.14
#1
New features:
- Many small bug fixes and improvements
- Mosaic 2.0 - a lot of improvements and ability to create your own widgets (documentation will be published later on)
- Import of ETS4/ETS5 project files via converter: http://openrb.com/knxproj/ If JSON import is not working correctly for you please send us your KNXPROJ file via e-mail

Make sure you have a backup file of your device prior to upgrading, downgrade to previous versions is only possible via firmware recovery.

LM2 IMX: http://dl.openrb.com/lm-16.07-rc/lm2i.img
LM3 V1 (4 x RS-485): http://dl.openrb.com/lm-16.07-rc/lm3v1.img
LM3 V2 (3 x RS-485 and 1 x RS-232): http://dl.openrb.com/lm-16.07-rc/lm3v2.img
LM4: http://dl.openrb.com/lm-16.07-rc/lm4.img
LM5: http://dl.openrb.com/lm-16.07-rc/lm5m4.img
LM Ambient: http://dl.openrb.com/lm-16.07-rc/lmwall.img
LM Reactor: http://dl.openrb.com/lm-16.07-rc/reactor.img
LM Reactor V2: http://dl.openrb.com/lm-16.07-rc/reactorv2.img
LM Reactor V3: http://dl.openrb.com/lm-16.07-rc/reactorv3.img
LM Reactor Lite: http://dl.openrb.com/lm-16.07-rc/rctl.img
#2
Hi just updated from previous stable version (9/2015) and saw some wired messages on the kernel logs like "EXT4-fs (mmcblk0p2): couldn't mount as ext3 due to feature incompatibilities" or error "EXT4-fs (mmcblk0p3): Mount option "nodelalloc" incompatible with ext3".
Is this normal?
#3
Also, after upgrade, old trends have seemed to stopped updating with new values (previous values are shown correctly).
A new trend that I created with 5 minutes resolution is working ok...
If I have to replace the old trends with new ones, is there a way to create a new trend (with minute resolution now that is supported) and import the values from the older trend so I can have all my data together again?
#4
After the update i can't start the Zwave daemon.

Daemon status: Stopped
#5
(14.07.2016, 19:38)jetsetter Wrote: Hi just updated from previous stable version (9/2015) and saw some wired messages on the kernel logs like "EXT4-fs (mmcblk0p2): couldn't mount as ext3 due to feature incompatibilities" or error "EXT4-fs (mmcblk0p3): Mount option "nodelalloc" incompatible with ext3".
Is this normal?
It's not an error, nothing to worry about Smile

(14.07.2016, 20:41)jetsetter Wrote: Also, after upgrade, old trends have seemed to stopped updating with new values (previous values are shown correctly).
A new trend that I created with 5 minutes resolution is working ok...
If I have to replace the old trends with new ones, is there a way to create a new trend (with minute resolution now that is supported) and import the values from the older trend so I can have all my data together again?
Can you send us your backup via e-mail?

(15.07.2016, 06:14)gjniewenhuijse Wrote: After the update i can't start the Zwave daemon.

Daemon status: Stopped
Have you tried upgrading the ZWave package from the store?
#6
(15.07.2016, 06:19)admin Wrote:
(15.07.2016, 06:14)gjniewenhuijse Wrote: After the update i can't start the Zwave daemon.

Daemon status: Stopped
Have you tried upgrading the ZWave package from the store?

After upgrading the package it works again. Smile

Thanks for upgrading the Zwave package.

Now it looks like my Greenwave Powernode 6 works great, i have 6 output switches.

But after the update i have some weird things:
- On the lm4 i have also a Fibaro FGRGBWM441 RGBW Controller, the devices properties are all in 6 pieces now. But i only need 1 parameter for this device, not 6.
- There is continues zwave traffic, i see the blue led of my usb zwave dongle flashing and some objects are continues green in the object tab.
- Also my outlet of the Greenwave Powernode 6 are sometimes switching off/on, and i have no logic for that. Then i see all zwave objects are updated in the objects tab.
#7
(14.07.2016, 12:44)admin Wrote: New features:
- Many small bug fixes and improvements
- Mosaic 2.0 - a lot of improvements and ability to create your own widgets (documentation will be published later on)
- Import of ETS4/ETS5 project files via converter: http://openrb.com/knxproj/ If JSON import is not working correctly for you please send us your KNXPROJ file via e-mail

Make sure you have a backup file of your device prior to upgrading, downgrade to previous versions is only possible via firmware recovery.

LM2 IMX: http://dl.openrb.com/lm-16.07-rc/lm2i.img
LM3 V1 (4 x RS-485): http://dl.openrb.com/lm-16.07-rc/lm3v1.img
LM3 V2 (3 x RS-485 and 1 x RS-232): http://dl.openrb.com/lm-16.07-rc/lm3v2.img
LM4: http://dl.openrb.com/lm-16.07-rc/lm4.img
LM5: http://dl.openrb.com/lm-16.07-rc/lm5m4.img
LM Ambient: http://dl.openrb.com/lm-16.07-rc/lmwall.img
LM Reactor: http://dl.openrb.com/lm-16.07-rc/reactor.img
LM Reactor V2: http://dl.openrb.com/lm-16.07-rc/reactorv2.img
LM Reactor V3: http://dl.openrb.com/lm-16.07-rc/reactorv3.img
LM Reactor Lite: http://dl.openrb.com/lm-16.07-rc/rctl.img

hello,

I have updated my logic machine reactor with the prerealease and this candidate version. 

Minor bug : 

- trends : resolution text for 5,10,15,20,30 is the same for all (0mn).

It will be interesting that after making a trend it'll be possible to change greys parameters (resolution for example)  if the user want to modify it after without erase it, and create a new trend.

Best regards
#8
Can you provide a screenshot with incorrect text? As for changing parameters, due to trend storage engine architecture most parameters can only be set during creation.
#9
admin
(14.07.2016, 20:41)jetsetter Wrote: Also, after upgrade, old trends have seemed to stopped updating with new values (previous values are shown correctly).
A new trend that I created with 5 minutes resolution is working ok...
If I have to replace the old trends with new ones, is there a way to create a new trend (with minute resolution now that is supported) and import the values from the older trend so I can have all my data together again?
Can you send us your backup via e-mail?
It seems that the strange "blankness" period was only for some hours (20:00 - 03:00) as you can see from the attached screen shot - notice also the two icons missing in the attached screenshot from the Mozilla firefox at the PC, in the other screenshot from safari at iPhone's screen are displayed but have other issue with alignment and create a double header line, as well as issue at the bottom axis displaying the hours.
This affected all trends, except the brightness ones (the brightness and temperature values comes from the same push-buttons) and a new temp trend that I created just after the firmware upgrade at 19:00...

Do you wan to send you the trends part of the backup file over email?
Also, please check my question about a possible way to create a new trend (with minute resolution) for an object and then fill all past values by importing them from an existing trend of the same object (but with hour resolution) so you can have a consolidated new trend and delete the old one.

tnx


Attached Files Image(s)
       
#10
[attachment=186 Wrote:admin pid='1691' dateline='1468578642']Can you provide a screenshot with incorrect text? As for changing parameters, due to trend storage engine architecture most parameters can only be set during creation.

see attachement

For changing parameters it'll be cool because when trend is erased, history is lost when a new  trend is created with new parameter.




Attached Files Image(s)
   
#11
HI, 

Did you try to use English language? It could be a translation problem because as far is I know not all new lines are translated yet.

If you select one of the 0mn options does it work anyway?

Can you test this and post the result?

Br,

Erwin
#12
(16.07.2016, 23:23)Erwin van der Zwart Wrote: HI, 

Did you try to use English language? It could be a translation problem because as far is I know not all new lines are translated yet.

If you select one of the 0mn options does it work anyway?

Can you test this and post the result?

Br,

Erwin

hello,

yes it work correctly with 0mn (all my T° trends on the first attachement are parametred with those parameters).

test in english is good without another modification text are 5, 10 and 20 minutes...
#13
(15.07.2016, 12:42)jetsetter Wrote: Also, please check my question about a possible way to create a new trend (with minute resolution) for an object and then fill all past values by importing them from an existing trend of the same object (but with hour resolution) so you can have a consolidated new trend and delete the old one.
Right now it's not possible, but we'll look into it.

(17.07.2016, 07:21)69jtdti Wrote: hello,

yes it work correctly with 0mn (all my T° trends on the first attachement are parametred with those parameters).

test in english is good without another modification text are 5, 10 and 20 minutes...
Thanks, it's indeed an issue with translation, will be fixed in the release.
#14
I have to report that with the latest release candidate, my 1-wire temp test probe works like a charm without any hickups (before I had issues with random stops of getting temp values for unknown reason).
Nice work!
#15
I have strange messages in the log after the update:
- /dev/mmcblk0p3: UNEXPECTED INCONSISTENCY; RUN fsck MANUALLY
- EXT4-fs (mmcblk0p3): warning: mounting fs with errors,
- EXT4-fs (mmcblk0p3): recovery complete

And it looks like the update is rolled back.
#16
I have a lot of DMX devices and I noticed that command response time is greatly increased in this firmware on LM3 V1 (4 x RS-485). I will roll back
#17
How many DMX channels in total do you have? There are some changes required for DMX library in order to work with new FW.
#18
Updated DMX user library for RC firmware:
https://gist.github.com/jsopenrb/f97f85f...c6766aae6a
#19
(17.08.2016, 07:44)admin Wrote: How many DMX channels in total do you have? There are some changes required for DMX library in order to work with new FW.
 
   channels = 57,
   transition = 1,

OK, I try today or tomorrow
#20
(17.08.2016, 16:21)Safar Wrote:
(17.08.2016, 07:44)admin Wrote: How many DMX channels in total do you have? There are some changes required for DMX library in order to work with new FW.
 
   channels = 57,
   transition = 1,

OK, I try today or tomorrow

More more better! With updated DMX library. I even see transition...))

And I notice that CPU consumption is lower than previous version

Thanks


Forum Jump: