This forum uses cookies
This forum makes use of cookies to store your login information if you are registered, and your last visit if you are not. Cookies are small text documents stored on your computer; the cookies set by this forum can only be used on this website and pose no security risk. Cookies on this forum also track the specific topics you have read and when you last read them. Please confirm whether you accept or reject these cookies being set.

Fronius inverter JSON integration
#1
Hi,

Does anybody have an implementation with Fronius inverter via JSON?


BR
Tomas
Reply
#2
Hi,

I have a script version, maybe this helps you with creating the JSON template.

.lua   Fronius Solar Inverter.lua (Size: 3.36 KB / Downloads: 83)


BR,

Erwin
Reply
#3
HI Erwin,

have you similar script for Kostal or something else?
Reply
#4
(01.06.2019, 09:57)Erwin van der Zwart Wrote: Hi,

I have a script version, maybe this helps you with creating the JSON template.



BR,

Erwin

Thanks Erwin!
Reply
#5
Hi Erwin,

Does this script work on the regular connection with the internet or is there a separate connection to the inverter.
They have installed a Fronius here today and i'm running the script resident with an interval of 60 seconds, but i get no data. Adjusted the IP and created objects in HL, no errors and no log.

Thx in advance
Novice DIY with a HL and KNX basics trying to ...
Reply
#6
This is old way of making Modbus TCP integration it work on local network. This should be converted to a profile.
Reply
#7
Hi 
in modbus section creat a new modbus tcp connection and try below Json

Attached Files
.json   fronius.json (Size: 4.02 KB / Downloads: 14)
Reply
#8
@Balatis,

File uploaded as a profile in Modbus section, connection created.

Error Log:

Fronius (TCP 192.168.XXX.XXX:502) connection failed: Connection refused.

I guess that the port is not right, but i can't find what port to set.

Thx

edit:
The pv system was installed last friday and i guess i don't have full admin access to the inverter and the modbus is not active on the inverter. i will call them first thing monday.
Novice DIY with a HL and KNX basics trying to ...
Reply
#9
Update:

Got on the phone with Fronius tech support and they gave me access to the inverter. Adjusted the modbus settings in the inverter and it's working now.

Thx
Novice DIY with a HL and KNX basics trying to ...
Reply
#10
As mentioned above, connection works, but i think i don't have the right setting in the modbus config because for some data i get really strange values. Or otherwise my datatype's are incorrect in HL

Modbus settings:

Gegevensoverdracht via Modbus: TCP
Modbus-poort: 502
String Control-adresoffset: 101
Sunspec Model Type: Float (can select int/SF)

Datatype in HL objects: 4 byte floating point
Novice DIY with a HL and KNX basics trying to ...
Reply
#11
(22.06.2020, 16:45)Firechief Wrote: As mentioned above, connection works, but i think i don't have the right setting in the modbus config because for some data i get really strange values. Or otherwise my datatype's are incorrect in HL

Modbus settings:

Gegevensoverdracht via Modbus: TCP
Modbus-poort: 502
String Control-adresoffset: 101
Sunspec Model Type: Float (can select int/SF)

Datatype in HL objects: 4 byte floating point 
if you have value , you have communication ..... maybe your type of inverter has deferment register list of values ....
The above json is for symo  10000w 
here there is all register data of all models 
https://www.fronius.com/en/photovoltaics...modbus-rtu
Reply


Forum Jump: