This forum uses cookies
This forum makes use of cookies to store your login information if you are registered, and your last visit if you are not. Cookies are small text documents stored on your computer; the cookies set by this forum can only be used on this website and pose no security risk. Cookies on this forum also track the specific topics you have read and when you last read them. Please confirm whether you accept or reject these cookies being set.

[PRE-RELEASE 3] LogicMachine firmware 2020.07
#21
(03.07.2020, 06:45)admin Wrote: Another notable feature is that LM now has built-in OpenVPN client and MQTT broker. OpenVPN can be configured from System Config, for MQTT broker you need install configuration app from the store.

Hi,

How can I config VPN conetion?
I´ve been looking for it in System Configuration and I haven´t found anything.

Thanks
Reply
#22
System - Services - OpenVPN
Reply
#23
I have installed this update on LM5 Lite (i.MX28) and there is no OpenVPN tab. It doesn't appear in System -> Services
Reply
#24
There is no openVPN in old HW.
Reply
#25
Is there a firmware for LB?
Reply
#26
(20.08.2020, 03:27)Alferov Wrote: Is there a firmware for LB?
LB is not supported anymore.
Reply
#27
after installing i have problems with the aes user lib that used:
http://dl.openrb.com/pkg/luaencdec_20180912_mxs.ipk

see also https://forum.logicmachine.net/showthrea...0#pid17990

and where to find the latest mosquitto packages?
Reply
#28
mosquitto library and broker are included by default, not need to install anything extra
Reply
#29
Screens hangs with a rotating wheel when starting my trends (/scada-vis/trends).

How to solve this?
Reply
#30
(21.08.2020, 12:32)gjniewenhuijse Wrote: Screens hangs with a rotating wheel when starting my trends (/scada-vis/trends).

How to solve this?
Can you describe this problem a little bit more?  What device do you use, what browser?
Reply
#31
Check browser dev console (F12) for errors
Reply
#32
(21.08.2020, 13:26)admin Wrote: Check browser dev console (F12) for errors

trends.js.gz?version=20200720:1 Uncaught TypeError: Cannot read property 'data' of null
    at trends.js.gz?version=20200720:1
    at Function.each (jquery.js.gz?version=20200720:14)
    at Object.draw (trends.js.gz?version=20200720:1)
    at trends.js.gz?version=20200720:1
    at Object.success (trends.js.gz?version=20200720:1)
    at l (jquery.js.gz?version=20200720:25)
    at Object.fireWith [as resolveWith] (jquery.js.gz?version=20200720:25)
    at C (jquery.js.gz?version=20200720:25)
    at XMLHttpRequest.<anonymous> (jquery.js.gz?version=20200720:25)
trends.js.gz?version=20200720:1 Uncaught TypeError: Cannot read property 'data' of null
    at trends.js.gz?version=20200720:1
    at Function.each (jquery.js.gz?version=20200720:14)
    at Object.draw (trends.js.gz?version=20200720:1)
    at o (jquery.js.gz?version=20200720:14)
(anonymous) @ trends.js.gz?version=20200720:1
each @ jquery.js.gz?version=20200720:14
draw @ trends.js.gz?version=20200720:1
o @ jquery.js.gz?version=20200720:14

(21.08.2020, 13:26)admin Wrote: Check browser dev console (F12) for errors

Edge error: SCRIPT5007: SCRIPT5007: Unable to get property 'data' of undefined or null reference

trends.js.gz (1,3441)
Reply
#33
Can you send backup so we can check locally?
Reply
#34
(21.08.2020, 13:43)admin Wrote: Can you send backup so we can check locally?

send by pm
Reply
#35
Thanks for the backup, unfortunately it looks like you had an SD card/file system corruption. Some of the trends are missing (both Elektra stand...) and the first trend file (Gas verbruik) is corrupt.
Reply
#36
(21.08.2020, 15:20)admin Wrote: Thanks for the backup, unfortunately it looks like you had an SD card/file system corruption. Some of the trends are missing (both Elektra stand...) and the first trend file (Gas verbruik) is corrupt.

Weird, so i removed the trends and its working again.

Please remove the backup from your testmachine.
Reply
#37
Hello.

I have some issues with the widgets in this new version. The other releases work fine, but this one isn´t working in the it´s expected. The widget doesn´t respect the page borders for it´s position. The first time I touch the widget it opens almost correctly, but depending on the place in the page, part of it can be off the page. From the second time and on that I touch it, the widget goes totally off the page.

BR,
Jefferson Campos
Reply
#38
(01.09.2020, 19:05)suporte.arqtech Wrote: Hello.

I have some issues with the widgets in this new version. The other releases work fine, but this one isn´t working in the it´s expected. The widget doesn´t respect the page borders for it´s position. The first time I touch the widget it opens almost correctly, but depending on the place in the page, part of it can be off the page. From the second time and on that I touch it, the widget goes totally off the page.

BR,
Jefferson Campos
Can you send me your backup to PM? I need to recreate this issue. Use wetransfer.com or similar.
Reply
#39
(02.09.2020, 07:14)Daniel. Wrote:
(01.09.2020, 19:05)suporte.arqtech Wrote: Hello.

I have some issues with the widgets in this new version. The other releases work fine, but this one isn´t working in the it´s expected. The widget doesn´t respect the page borders for it´s position. The first time I touch the widget it opens almost correctly, but depending on the place in the page, part of it can be off the page. From the second time and on that I touch it, the widget goes totally off the page.

BR,
Jefferson Campos
Can you send me your backup to PM? I need to recreate this issue. Use wetransfer.com or similar.
Thanks for the backup. We will look at it. In the meantime you can fix it by adding fixed position to the widget.
Reply
#40
(06.07.2020, 06:14)admin Wrote: @Bitver
We might implement WireGuard later. OpenVPN has been selected due to being one of the most popular and supported solution.

Here's one more vote for WireGuard. It's faster and lighter on CPU + easy setup.
Reply


Forum Jump: