This forum uses cookies
This forum makes use of cookies to store your login information if you are registered, and your last visit if you are not. Cookies are small text documents stored on your computer; the cookies set by this forum can only be used on this website and pose no security risk. Cookies on this forum also track the specific topics you have read and when you last read them. Please confirm whether you accept or reject these cookies being set.

[PRE-RELEASE 3] LogicMachine firmware 2020.07
#61
@Thomas, thanks for letting us know
Reply
#62
i. I have an old MX LM reactor v2 and cannot get i updated firmware. It looks like everything goes allright and it reboots as it should but I still get the old firmware when I see on the firmware page. 
I also sometimes see that the LM hangs and I have to restart it as scripts doesnt run as excpected. I have about 100 trends running but at the same time lost about 90 of them
what can be wrong?
The logs then doesnt show clock etc when I look on it in trends window.
Here are some screen shots
  
Reply
#63
SD card is most likely in read only mode.
Reply
#64
(29.12.2020, 10:17)Daniel. Wrote: SD card is most likely in read only mode.
The card has been changed once and updated til 2018 firmware but cannot upgrade from here. Can i test the sd card somehow? Can it suddenly be changed to read only from lm?
Reply
#65
I got a new SD card, and used the reflash sd card link( https://openrb.com/reflash-logicmachine3...-software/ )
Now I got the Logic machine up to 2020 versionSmile Thanks for the help Daniel
Reply
#66
Hi,

Thanks for this update: it's always promising to see new features emerging  Wink.
I noticed that since I upgraded to this version, the "scene.tagset" function (available through the genohm-scada library) is now broken. The error is also present when using the tagenable and tagdisable function. The error I get is "bad argument #1 to 'ipairs' (table expected, got string).

I've tried specifying the tagname as a table to no avail: scene.tagset({'tagname'},true) instead of scene.tagset('tagname',true).

It seems like my scenes are all still there as they were before the update, tags and all.

Any idea on how I could solve this?

Thanks in advance!
Reply
#67
@cedricdw, thanks for letting us know, this will be fixed in the next FW
Reply
#68
After changing sd card and updating all trend data is lost? Some trends seems corrupt. And some seems to be without data.
Reply
#69
I have two LM4 where I have to replace the read-only SD card.
I would like to take the opportunity to update the firmware. The current firmware is 20160714.
I would first replace the SD card with the current firmware and then do the update. Can I update directly to 2020.07 or should I do the updates in chronological order?
Reply
#70
I have replaced my older internal MicroSD card with a SanDisk Industrial SLC 32GB purchased from Mouser. Highly recommended, in case that you don't want to end up in replacing again the MicroSD card after few years due to system corruption.

In case that you don't manage to replace yourself the card, just send the Logic Machine to OpenRB and they will replace the MicroSD for you.

Attached Files Image(s)
   
Reply
#71
Good card but rather expensive and 32GB is not needed for LM. Even 1GB should be fine, just look for cards marked for industrial use. Pseudo-SLC and ultra MLC are fine as well. LM software is optimized to have a minimal amount of writes to the card so real SLC is not needed in most cases.
Reply


Forum Jump: