This forum uses cookies
This forum makes use of cookies to store your login information if you are registered, and your last visit if you are not. Cookies are small text documents stored on your computer; the cookies set by this forum can only be used on this website and pose no security risk. Cookies on this forum also track the specific topics you have read and when you last read them. Please confirm whether you accept or reject these cookies being set.

[PRE-RELEASE 1] LogicMachine firmware 2021.05
#1
2021 RC 1 is ready for testing. This version fixes several bugs from 2021 Beta 1. Our main focus was fixing bugs and improving usability in Mosaic30.

Video tutorials: https://forum.logicmachine.net/showthrea...9#pid21069

All recent firmware versions display which hardware is used in "HW (CPU)" form:
[Image: attachment.php?aid=1740]

LM5 Power devices with i.MX6 CPU
Extra packages: http://dl.openrb.com/lm-21-imx6/pkg

Devices with old CPU (i.MX28) Extra packages: http://dl.openrb.com/lm-21-mxs/pkg

Changes from 2020 RC3

Code:
2020.07.27
  scripting editor:
  - add save action for CTRL+S
  - clear undo history on load so CTRL+Z does not clear the whole script
  - fix indentation error for "e", "n", "d" characters

2020.08.19
  visualization: fix layout issue on certain configurations with slider in RGBW widget

2020.08.24
  trends: add automatic trend log file creation if file is missing or corrupted
  visualization: fix pin code for string types

2020.08.28
  bacnet: add custom device name setting

2020.09.24
  modbus: add status object for slave devices

2020.09.25
  storage: add mosaic keys to ignore list
  localbus: add "nobuswrite" field to event table for to grp.update
  visualizaion: enable top bar work-around for iOS v11+ instead of only v11
  visualizaion: fix positioning for nested widgets
  visualizaion: small style fix for touch/mobile visualization

2020.09.30
  visualization: add option to hide home button in touch mode

2020.10.12
  modbus: add support for writing values with bitmask

2020.10.15
  lm: add password support to knxproj import

2020.10.23
  user access:
  - add enable/disable option
  - add per-app access control
  - cache acl instead of using db queries for each request
  - add optional object access list

2020.10.27
  user access: add per-room user access to mosaic

2020.10.29
  modbus: fix polling sequence for longer polling times
  lm: add dali test result data type
  trends: change heartbeat from 120 seconds to 1 week (604800 seconds)
  trends: fix yearly display for min/max/last
  schedulers: add missing doctype
  vis: set fixed size for navbar buttons

2020.11.02
  modbus: add TCP option to read test UI

2020.11.03
  user access: show apps/mosaic/advanced access

2020.11.11
  user access: add cloud login field

2020.11.12
  visualization: fix control scaling for webkit browsers
  vis.params: fix 4-bit params not saving due to duplicate window id

2020.11.26
  knx filtering (IP/per-user): allow double asterisk (1/*/*)
  bacnet client: move scandevice/scandevices functions to the bacnet library
  modbus: allow read_count/read_offset usage for coils as well as registers
  scripting editor: show current value when running an event script
  visualization: use correct decimal settings for graph element

2020.11.30
  bacnet: show correct device name in object list
  http: add "x-frame-options: sameorigin" header with an option to disable it
  trends: fix labels not showing in certain cases
  user access: add cloud user list to cached acl

2020.12.02
  knxproj import: use datatype from group connection if possible
  trends: show error message when trend load fails due to a missing trend file

2020.12.11
  trends: do not hide export button when a single trend is displayed
  modbus: cache and reuse persistent TCP connections based on IP:PORT pair

2020.12.18
  user access: log/block access attempts with unknown username
  objects: fix pagination display after reload when filtering is active
  apps: hide core apps from the list when user has no access to this module

2021.01.05
  scenes: fix scene.tagset() function

2021.01.06
  security: add "X-Content-Type-Option: nosniff" header to user uploads

2021.01.18
  knx/ip: fix secure mode timer and duplicate message tag after outdated frame has been received

2021.01.19
  modbus: ignore devices with polling time less than zero, try writing once in 60 seconds for devices marked as offline

2021.01.21
  security: disallow KNX/IP Tunneling connections from external IPs

2021.01.22
  system config: fix ntp client disable not being allowed with empty peer list
  modbus: fix writing address when read_offset is used
  modbus: fix write_address field missing in the database
  modbus: try reading only once for devices that are marked offline

2021.02.03
  modbus: fix mapping sorting by type/address

2021.02.04
  modbus: add NaN check for floating point values after conversion when value_nan is not set
  modbus: add missing value_default field

2021.02.22
  system config: add user accounts and passwords to backup/restore

2021.03.22
  schedulers: fix minor layout issues, fix race condition when one scheduler sets status for another

2021.03.23
  user access: allow "+" in local/cloud login

2021.03.25
  flashsys: do a full backup (not partial which can skip trends) before doing the fw upgrade
  visualization editor: show icon when the object value is empty, otherwise it's not possible to select/move this object

2021.03.29
  user access: hide removed apps from the access list

2021.04.08
  storage: memory usage optimizations for large requests

2021.04.12
  trends: allow NaN value for float32

2021.04.13
  security: disable remote services if default password is used

2021.04.22
  apps: fix accidental web server stop after app installation

2021.04.26
  modbus: fix slave ID reset to 247 when editing a TCP device with id > 247

2021.04.29
  modbus: fix order for multiple mapping option
Reply
#2
Hello 
Great features in this release and keep going 
I found that the Configure Apps page didn't open.
I log in as admin and I clear the cash but I still can't open the Configure Apps page

regards,
Reply
#3
Which browser, OS?
BTW, now you can do the same in user settings and allow apps per user.
Reply
#4
(17.05.2021, 09:57)Daniel. Wrote: Which browser, OS?
BTW, now you can do the same in user settings and allow apps per user.

Google Chrome used
I log in as Admin
Reply
#5
Anything in the browser error log (F12)?
Reply
#6
(17.05.2021, 10:50)admin Wrote: Anything in the browser error log (F12)?

(index):1 Uncaught (in promise) {}message: (...)get message: ƒ ()arguments: (...)caller: (...)length: 0name: ""__proto__: ƒ ()[[Scopes]]: Scopes[0]__proto__: constructor: ƒ ()__proto__: Object

index.js:1 Uncaught (in promise) {}
(anonymous) @ index.js:1
apps.js.gz?v=20210413:1 Uncaught TypeError: Cannot read property 'toLowerCase' of undefined
    at sortByKey (apps.js.gz?v=20210413:1)
    at sortByTitle (apps.js.gz?v=20210413:1)
    at Array.sort (<anonymous>)
    at ne (apps.js.gz?v=20210413:1)
    at oe (apps.js.gz?v=20210413:1)
    at Object.success (apps.js.gz?v=20210413:1)
    at i (jquery.js.gz?v=20210413:2)
    at Object.fireWith [as resolveWith] (jquery.js.gz?v=20210413:2)
    at z (jquery.js.gz?v=20210413:4)
    at XMLHttpRequest.<anonymous> (jquery.js.gz?v=20210413:4)
sortByKey @ apps.js.gz?v=20210413:1
sortByTitle @ apps.js.gz?v=20210413:1
ne @ apps.js.gz?v=20210413:1
oe @ apps.js.gz?v=20210413:1
success @ apps.js.gz?v=20210413:1
i @ jquery.js.gz?v=20210413:2
fireWith @ jquery.js.gz?v=20210413:2
z @ jquery.js.gz?v=20210413:4
(anonymous) @ jquery.js.gz?v=20210413:4
load (async)
send @ jquery.js.gz?v=20210413:4
ajax @ jquery.js.gz?v=20210413:4
ie @ apps.js.gz?v=20210413:1
Config.show @ apps.js.gz?v=20210413:1
(anonymous) @ apps.js.gz?v=20210413:1
dispatch @ jquery.js.gz?v=20210413:3
r.handle @ jquery.js.gz?v=20210413:3
Reply
#7
after updating my LM Ambient, my Pm25 is empty. Is that correct?

type: LMWECO2-ZR - LogicMachine Ambient with Air Quality sensor and Enocean (Zebrano)
Reply
#8
Hi,



I have noticed that in all the machines where I have installed the latest updates (LM and Schneider wiser and Spacelynk), the remote connection ets via natted port 3671 no longer works. if i connect from lan obviously it works, but on previous port natted it doesn't work anymore.


is it a bug on the new firmware? What I have to do?

Thanks

Peppe
Reply
#9
This is blocked on purposes. Use zerotier for secure remote commissioning.
Reply
#10
(18.05.2021, 14:48)Daniel. Wrote: This is blocked on purposes. Use zerotier for secure remote commissioning.

Sorry, I don't understand. What I have to do to keep using natted 3671 port?
Reply
#11
https://openrb.com/zerotier-remote-maintenance-of-lm5/
Reply
#12
ok, but how I can do with schneider spacelynk / wiser?
Reply
#13
https://forum.logicmachine.net/showthread.php?tid=3364
Reply
#14
ok, so, if I understood, there is no solution right now. Can I almost downgrade the firmware?
Reply
#15
Hello,

what is correct firmware for LM5Cp2-RIO2??
Reply
#16
When you open the firmware upgrade window it will tell you which hardware model you have (as mentioned in the first post). RIO2 is LM5 Reactor IO V2.
Reply
#17
admin,

thank you. Now all is clear Smile
Reply


Forum Jump: