This forum uses cookies
This forum makes use of cookies to store your login information if you are registered, and your last visit if you are not. Cookies are small text documents stored on your computer; the cookies set by this forum can only be used on this website and pose no security risk. Cookies on this forum also track the specific topics you have read and when you last read them. Please confirm whether you accept or reject these cookies being set.

Amazon Echo / Alexa app
#21
Hi
There is new version of Alexa on the store. There was some issue with mqtt broker. Try if it helps.
Reply
#22
(21.06.2017, 10:06)morak Wrote: Hi
There is new version of Alexa on the store. There was some issue with mqtt broker. Try if it helps.

Thank you for the reply morak.

I have updated the app, then it seems to work for 3-4 continuous commands, but it started to randomly missing commands executions again afterwards... also so far I have no errors in LM after the app update.

Then I thought to try to upgrade also my LM to RC4. Everything went fine and the upgrade also installed the Mosaic 2.0 app automatically (I had remove it to check if Mosaic trying to connect also to cloud was the problem) but alexa App just doesn't want to work all the time... How can I debug this? 

One other thing is that there are two "LogicMachine Skills" for someone to enable within Amazon Echo iOS App and I just pick the first, maybe this is also an issue? 

I seems strange that there are not many user replies if they have Alexa issues or not... 
Maybe not so many people is using the Alexa App after all?

I wish we had a reliable LM alexa app operation, as once you get used to the verbal commands it is very difficult to go back to searching for your mobile for turning on a light...
Reply
#23
There was an issue with cloud communication, please try again and see if it is working correctly now.
Reply
#24
I tried but there are still command miss-executions as well as related errors in log too:
"Error log 27.06.2017 19:10:01 Line 350: MQTT.client:handler(): Not connected"

If I understand correctly, this cloud communication issue you are referring should affect all LM with Alexa app users (not only me) or I am the only one that has this issues and anyone else is commanding their LM through Alexa echo normally??

Please note that in the Amazon-own Alexa iOS app, there are two "LogicMachine Smart Home Skills by Embedded Systems SIA" that can be enabled (I don't understand why there are two or what is the difference between the two skills), maybe they are using different cloud communication so that is my problem and therefore I need to disable the one I am using and enable the other one?
Reply
#25
The "Line 350: MQTT.client:handler(): Not connected" from the hidden alexa script is still popping in my error logs...

At least, it would be useful to know if this is happening only to me or not.
Reply
#26
(12.07.2017, 08:44)jetsetter Wrote: The "Line 350: MQTT.client:handler(): Not connected" from the hidden alexa script is still popping in my error logs...

At least, it would be useful to know if this is happening only to me or not.

I have too,
Reply
#27
(13.07.2017, 15:26)nhieulk Wrote:
(12.07.2017, 08:44)jetsetter Wrote: The "Line 350: MQTT.client:handler(): Not connected" from the hidden alexa script is still popping in my error logs...

At least, it would be useful to know if this is happening only to me or not.

I have too,

Any update on the Alexa app? Current version is almost unusable...
Reply
#28
Thumbs Up 
(10.08.2017, 13:29)jetsetter Wrote:
(13.07.2017, 15:26)nhieulk Wrote:
(12.07.2017, 08:44)jetsetter Wrote: The "Line 350: MQTT.client:handler(): Not connected" from the hidden alexa script is still popping in my error logs...

At least, it would be useful to know if this is happening only to me or not.

I have too,

Any update on the Alexa app? Current version is almost unusable...

Current version is work.  Smile
Reply
#29
I'm also facing the same problems as some of the other Alexa app users. Sometimes it works, but then after a few commands it breaks and nothing happens. Alexa always returns with the "OK", so the commands was received and AVS found the correct resource/device, but the LM3 is not receiving the command.

How can I help debug the issue? Do we have access to a Alexa diagnostic log?
Reply
#30
(13.08.2017, 19:34)morten Wrote: I'm also facing the same problems as some of the other Alexa app users. Sometimes it works, but then after a few commands it breaks and nothing happens. Alexa always returns with the "OK", so the commands was received and AVS found the correct resource/device, but the LM3 is not receiving the command.

How can I help debug the issue? Do we have access to a Alexa diagnostic log?

Dear Morten,

Can you check account log in alexa app and account in LM. 

I think you can check log in alexa app. When I log in, I see command when you use with alexa.
Thanks & Best Regards
Reply
#31
(15.08.2017, 09:44)nhieulk Wrote:
(13.08.2017, 19:34)morten Wrote: I'm also facing the same problems as some of the other Alexa app users. Sometimes it works, but then after a few commands it breaks and nothing happens. Alexa always returns with the "OK", so the commands was received and AVS found the correct resource/device, but the LM3 is not receiving the command.

How can I help debug the issue? Do we have access to a Alexa diagnostic log?

Dear Morten,

Can you check account log in alexa app and account in LM. 

I think you can check log in alexa app. When I log in, I see command when you use with alexa.


Thanks for the reply. I'm not sure where to find the Alexa log. Are you referring to the command history user Settings->General->History? In regards to the LM there is nothing in the Error Log or Logs about Alexa. Is there a more low-level log I should check?
Reply
#32
I have same issue, alexa is receiving the commands but nothing happen. working only from time to time...
Reply
#33
Hi
Please gave another try to Alexa. There was issue on the cloud which was just solved. My Alexa started to work now as it should Smile
BR
Reply
#34
(22.08.2017, 14:50)Daniel. Wrote: Hi
Please gave another try to Alexa. There was issue on the cloud which was just solved.  My Alexa started to work now as it should Smile
BR

I don't know how extensive you tested your setup, but I saw your post and tested it again yesterday all day and found that sometimes it could execute all 6 out of 6 of my consecutive commands, but after a while it began again to miss some of them (1-2 out of 6) and after another while it began missing most of them.... 

I checked also my logs and found again some "Line 350: MQTT.client:handler(): Not connected" errors from both "alexa" and "mosaic20" scripts... Has anyone understand who is responsible for this "cloud issue"? 

Unfortunately, working normally from time to time is NOT as it should.... It is quite disappointing...
Reply
#35
(25.08.2017, 14:59)jetsetter Wrote:
(22.08.2017, 14:50)Daniel. Wrote: Hi
Please gave another try to Alexa. There was issue on the cloud which was just solved.  My Alexa started to work now as it should Smile
BR

I don't know how extensive you tested your setup, but I saw your post and tested it again yesterday all day and found that sometimes it could execute all 6 out of 6 of my consecutive commands, but after a while it began again to miss some of them (1-2 out of 6) and after another while it began missing most of them.... 

I checked also my logs and found again some "Line 350: MQTT.client:handler(): Not connected" errors from both "alexa" and "mosaic20" scripts... Has anyone understand who is responsible for this "cloud issue"? 

Unfortunately, working normally from time to time is NOT as it should.... It is quite disappointing...
Hi
Since my last post my alexa did respond to every single command. Can we get acces to your device to check the error ?
BR
Reply
#36
(25.08.2017, 15:08)Daniel. Wrote: Hi
Since my last post my alexa did respond to every single command. Can we get acces to your device to check the error ?
BR

Hi Daniel. Since my last post my Alexa didn't miss a command either and the last error I got was the previous one at 24/8....
Thank you for trying to help, Are you part of, or related to the Alexa app development team?

Also now that it finally working as it should (fingers crossed) anyone tried to:
1) setup devices with multiple names (like "Parrents bed light" and "Parrents hall light") and then controlled them separately? It seams that Alexa can only recognize the first word of the device name ("Parrents") and gets confused..
2) Control a shutter? I tried to do this through light dimming
3) Can you monitor a contact status i.e. a door)? 

Is there any documentation on what commands are supported by the logicmachine skill other than its description?
Reply
#37
(26.08.2017, 14:35)jetsetter Wrote:
(25.08.2017, 15:08)Daniel. Wrote: Hi
Since my last post my alexa did respond to every single command. Can we get acces to your device to check the error ?
BR

Hi Daniel. Since my last post my Alexa didn't miss a command either and the last error I got was the previous one at 24/8....
Thank you for trying to help, Are you part of, or related to the Alexa app development team?

Also now that it finally working as it should (fingers crossed) anyone tried to:
1) setup devices with multiple names (like "Parrents bed light" and "Parrents hall light") and then controlled them separately? It seams that Alexa can only recognize the first word of the device name ("Parrents") and gets confused..
2) Control a shutter? I tried to do this through light dimming
3) Can you monitor a contact status i.e. a door)? 

Is there any documentation on what commands are supported by the logicmachine skill other than its description?

Hi
Yes I'm part of EMBS.
1) I'm using name like 'Office one' and 'Office two' and Alexa is picking up them pretty well. I think it is only up to alexa being able to understand your pronunciations. Don't know where are you based but she could use US or UK accent.  Anyhow alexa range is limited by voice so you should name only objects around her and keep it as simple for her to understand.
2) Alexa can understand only sentence which are defined by Amazon. If you would say 'Alexa turn ON Shutter' then she will send 1 to shutter object and opposite to turn off. Or you can say 'Alexa set shutter to 100%' 
3) She should be able to check if door is lock.  This is the only part for door what amazon created. We are limited from Amazon side for the commands.
There is new functionality Scenes and we are going to add this at some point.
BR
Reply
#38
How do you activate scenes? Would be great if you could activate a scene defined inside the logic machine by saying "alexa, turn on home".
Reply
#39
Hi,

You can trigger any object from Alexa and use these (event based) script commands to control the internal scenes.

http://www.openrb.com/docs/lua.htm#11

You probably want to use:
Code:
scene.run('yourscenename')

BR,

Erwin
Reply
#40
@Daniel: As you are part of EMBS, can you please clarify to me some things based on your previous reply:
  1. Is it possible to ask Alexa for a light status i.e. "Alexa is Kitchen Spotlight On?" or "Alexa, what is the status of Kitchen Spotlight?". As far as I have seen on other skill implementations, it is possible for Alexa to respond to such questions by reading the status group address given inside the Alexa App configuration.
  2. I understand that the actual description you want to call for a light, should be placed in the "Friendly Name" field of Alexa App configuration. There is also a "Friendly Description" field does this also used by Alexa or it is just cosmetic or should I put there also the room name that the light belongs to? I have noticed that if I name one light like "kitchen spots" and another one "kitchen led" for example, and then I try to ask "Alexa, turn on kitchen led", she only gets the "kitchen" part ignoring the "led" so i get the "a few devices share this common name, Which one do you prefer?" answer (this has nothing to do with my accent). Have you configure your lights such way too and get them understood correctly by her?
  3. Besides an "AC on/off" switch, I have also created two other temperature objects in LM, one is used as my "AC setpoint" and the other for my "AC setpoint status". Then I created a thermostat device in Alexa App, and selected the "AC setpoint" group address in the Temperature object field and the "AC setpoint status" group address in the Temperature status object field. I can turn my AC on/off ok, but I am geting a "hmm, AC is not responding" answer when I ask her "Alexa, set AC to 25 degrees". Any ideas?
Thank you in advance!
Reply


Forum Jump: