This forum uses cookies
This forum makes use of cookies to store your login information if you are registered, and your last visit if you are not. Cookies are small text documents stored on your computer; the cookies set by this forum can only be used on this website and pose no security risk. Cookies on this forum also track the specific topics you have read and when you last read them. Please confirm that you accept these cookies being set.

[RELEASE] LogicMachine firmware 2021.12
#1
LM firmware release 2021.12 is ready. This version fixes several minor bugs from 2021 RC3. Mosaic30 beta is now the stable version.

Video tutorials: https://forum.logicmachine.net/showthrea...9#pid21069

You can find the hardware model in the "Upgrade firmware" window:
[Image: attachment.php?aid=1740]

LM5 Power devices with i.MX6 CPU Extra packages (i.MX6 CPU)

Devices with old CPU (i.MX28) Extra packages (i.MX28 CPU)

Changes from 2021 RC3
Code:
2021.10.27
  user access: fix cloud login showing as "1" when empty

2021.11.03
  objects: add range setting for virtual objects
  schedulers: fix scheduler holidays access setting not working
  apps: fix partial apps user access

2021.11.17
  apps: show core app links when apps access is set to "none"

2021.12.13
  knx project import: switch datatype field priority as a work-around for invalid object links in the project file
Reply
#2
Hi, I think there is an error. In the update, Mosaic Beta disappears from the home page and it is not possible to access it. On the applications page it appears as installed and without the logo image. I have tried to remove it to reinstall it but it does not appear on the installation page.
Reply
#3
Mosaic beta is not beta anymore. Use Mosaic 3.0.
------------------------------
Ctrl+F5
Reply
#4
Would there be an FW update for the Load Balancer?
Reply
#5
Load Balancer is not supported anymore.
Reply
#6
It may be a coincidence, but after the FW update, the "ball" is just spinning when entering the window for apps. What can I look for to find the error?
Reply
#7
(22.12.2021, 13:50)Rune Wrote: It may be a coincidence, but after the FW update, the "ball" is just spinning when entering the window for apps. What can I look for to find the error?

Start by clearing browser cache, check for errors in the console F12
------------------------------
Ctrl+F5
Reply
#8
(22.12.2021, 14:48)Daniel Wrote:
(22.12.2021, 13:50)Rune Wrote: It may be a coincidence, but after the FW update, the "ball" is just spinning when entering the window for apps. What can I look for to find the error?

Start by clearing browser cache, check for errors in the console F12

If others experience the same thing, it seems to be the remote function in ISE Remote Access. Works fine on the IP directly.
Reply
#9
Hello,

is it possible to get the LM firmware on a Wiser for KNX (W4K)? I think its nearly the same hardware, but with the SE firmware. 


Best regards,
Muetzli
Reply
#10
No it's not.
------------------------------
Ctrl+F5
Reply
#11
After FW, mosaic and LM Cloud uptate i have lost all the mosaic configuration.
I cleaned mosaic configuration, unistall and reinstalled it but still no icons on either admin or normal page.

On the console i do get the error below:
Code:
failed to load widgets
Arguments(3) [{…}, 'parsererror', SyntaxError: Unexpected identifier
    at eval (<anonymous>)
    at http://xxxxxx.dyndns.org:xxxxxx/…, callee: ƒ, Symbol(Symbol.iterator): ƒ]
0:
abort: ƒ (a)
always: ƒ ()
complete: ƒ ()
done: ƒ ()
error: ƒ ()
fail: ƒ ()
getAllResponseHeaders: ƒ ()
getResponseHeader: ƒ (a)
overrideMimeType: ƒ (a)
pipe: ƒ ()
progress: ƒ ()
promise: ƒ (a)
readyState: 4
responseText: "$(function(){\n    Widget['n-air-condition'] = .....

At some point i had added a custom widget named "n-air-condition" but never used it.
Can you please let me know how to clear this reference?
Reply
#12
@gtsamis, run this script once:
Code:
os.execute('rm -rf /www/apps/data/mosaic30/widgets/u/*')
Reply
#13
(28.12.2021, 06:21)admin Wrote: @gtsamis, run this script once:
Code:
os.execute('rm -rf /www/apps/data/mosaic30/widgets/u/*')

Worked fine, thank you!
Reply
#14
(27.12.2021, 10:49)Daniel Wrote: No it's not.

Thanks for your reply.

BR,
Muetzli
Reply
#15
Hi guys,

did anybody have any issues upgrading to 2021.12 ?
I upgraded from 2020.07 and my LM is kind of bricked.
I can't see it anymore in my network clients, it's not getting any IP address and it's basically unreachable.
I tried resetting it but nothing. It's powered from POE as always but it shuts down after a few minutes.

Do you have any ideas?
Thanks!
LM5 Lite + Ext (i.MX6)
Reply
#16
Might be a corrupted SD card. The best solution is to get a new one and do a full reflash. See this guide: https://openrb.com/reflash-logicmachine3...-software/
Reply
#17
(03.01.2022, 07:56)admin Wrote: Might be a corrupted SD card. The best solution is to get a new one and do a full reflash. See this guide: https://openrb.com/reflash-logicmachine3...-software/

You were right, thank you!  Smile
LM5 Lite + Ext (i.MX6)
Reply


Forum Jump: